Bug 97845 - ppp connection establishment fails with error 28 (script interaction problem)
ppp connection establishment fails with error 28 (script interaction problem)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: initscripts (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
: 98781 (view as bug list)
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-06-23 03:15 EDT by Barry K. Nathan
Modified: 2014-03-16 22:37 EDT (History)
2 users (show)

See Also:
Fixed In Version: 7.33-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-15 01:42:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/sysconfig/network-scripts/ifcfg-UCI_lifeline (396 bytes, application/octet-stream)
2003-06-23 19:49 EDT, Barry K. Nathan
no flags Details
/etc/sysconfig/networking/ifcfg-lo (254 bytes, application/octet-stream)
2003-06-23 19:50 EDT, Barry K. Nathan
no flags Details
/etc/sysconfig/network-scripts/ifcfg-eth0 (74 bytes, application/octet-stream)
2003-06-23 19:53 EDT, Barry K. Nathan
no flags Details
patch against initscripts-7.28-1 to attempt to fix this bug (393 bytes, patch)
2003-07-30 03:28 EDT, Barry K. Nathan
no flags Details | Diff

  None (edit)
Description Barry K. Nathan 2003-06-23 03:15:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030619

Description of problem:
I set up a PPP connection in redhat-network-config, and it did not work from
either redhat-network-config or ifup. I think it shouldn't be hard to fix this
problem, but I may need suggestions from someone who is more familiar with the
philosophy behind the network scripts before I can code up a patch. (Or maybe I
just need to try again with a Red Hat release and see what happens in a working
configuration.)

Note that I'm not at all sure whether this is a redhat-config-network problem or
an initscripts problem.

Version-Release number of selected component (if applicable):
initscripts-7.24-2.92
redhat-config-network-1.3.0-1

How reproducible:
Always

Steps to Reproduce:
1. Set up a PPP connection in redhat-config-network.
2. Save your settings.
3. Try to activate it.

Actual Results:  Failed to activate ppp0 with error 28

Expected Results:  A PPP connection should have been established.

Additional info:

"ifup UCI_lifeline" (UCI_lifeline is the name of my PPP config in
redhat-config-network) eventually does this:
exec /etc/sysconfig/network-scripts/ifup-ppp
../networking/profiles/default/ifcfg-UCI_lifeline

and that eventually does this:
exec /sbin/ppp-watch ppp0 ''

and ppp-watch eventually (does something that) spits out the error 28 error message.

If I manually run the following command, I get a successful connection:
/sbin/ppp-watch UCI_lifeline

If you need any of my config files, just ask and I'll attach them or whatever.
Comment 1 Bill Nottingham 2003-06-23 10:53:16 EDT
Yeah, this is an issue with how it's reading profiles. Can you attach
/etc/sysconfig/network-scripts/ifcfg-*?
Comment 2 Barry K. Nathan 2003-06-23 19:49:17 EDT
Created attachment 92570 [details]
/etc/sysconfig/network-scripts/ifcfg-UCI_lifeline

This is my PPP connection.
Comment 3 Barry K. Nathan 2003-06-23 19:50:38 EDT
Created attachment 92571 [details]
/etc/sysconfig/networking/ifcfg-lo
Comment 4 Barry K. Nathan 2003-06-23 19:53:38 EDT
Created attachment 92572 [details]
/etc/sysconfig/network-scripts/ifcfg-eth0
Comment 5 Barry K. Nathan 2003-06-23 19:57:10 EDT
/etc/sysconfig/network-scripts/ifcfg-lo is a symlink to
/etc/sysconfig/networking/ifcfg-lo.

I've attached all of /etc/sysconfig/network-scripts/ifcfg-* now. (I someitmes
connect this machine to Ethernet networks and sometimes use dialup, thus the
presence of ifcfg-eth0 as well as ifcfg-UCI_lifeline.) If you need any more info
or whatever, just ask.
Comment 6 Barry K. Nathan 2003-06-25 00:46:13 EDT
As of initscripts-7.25-1:
"ifup UCI_lifeline" now ends with this instead:
exec /etc/sysconfig/network-scripts/ifup-ppp ifcfg-UCI_lifeline

But that still leads to:
exec /sbin/ppp-watch ppp0 ''

And that still fails with error 28.
Comment 7 Barry K. Nathan 2003-07-30 03:28:43 EDT
Created attachment 93253 [details]
patch against initscripts-7.28-1 to attempt to fix this bug

I don't know whether the bug is in ifup-ppp or in ppp-watch. This patch blindly
assumes the former.

This gets me to the point that redhat-config-network will dial up, and appear
to freeze at "Activating network device UCI_lifeline, please wait...". (Is
r-c-n waiting for ppp-watch to exit? I don't know how previous RHL released
worked in this regard, but ppp-watch doesn't exit on its own nowadays.) I'm
going to see what happens when I click "Cancel", but first I want to get this
attachment into Bugzilla.
Comment 8 Barry K. Nathan 2003-07-30 03:34:54 EDT
Ok, clicking "Cancel" changes the message to "Cannot activate network device
UCI_lifeline!" but keeps the dialog box on the screen and keeps the network
connection up.
Comment 9 Barry K. Nathan 2003-07-30 03:48:09 EDT
Clicking "OK" dismisses the dialog box, but r-c-n still seems to think the PPP
connection isn't active ("Activate" is still clickable, while "Deactivate" is
grayed out). /sbin/ifconfig shows that the PPP connection is clearly up. r-c-n
is still clueless after I quit it and start it up again.

At some point during my last few comments, ppp-watch died but pppd lived on.
Comment 10 Barry K. Nathan 2003-07-30 03:52:02 EDT
[root@i5000e network-scripts]# /sbin/ifdown ppp0
usage: ifdown <device name>
[root@i5000e network-scripts]# /sbin/ifdown UCI_lifeline
[root@i5000e network-scripts]# ifconfig ppp0
ppp0      Link encap:Point-to-Point Protocol
          inet addr:128.195.186.183  P-t-P:128.195.186.130  Mask:255.255.255.255
         UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
          RX packets:1213 errors:1 dropped:0 overruns:0 frame:0
          TX packets:1121 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:1100195 (1.0 Mb)  TX bytes:126499 (123.5 Kb)
                                                                                
It looks like nothing short of actually killing pppd is going to terminate my
connection...
Comment 11 Bill Nottingham 2003-08-02 01:21:47 EDT
*** Bug 98781 has been marked as a duplicate of this bug. ***
Comment 12 Bill Nottingham 2003-09-15 01:36:24 EDT
This should be fixed in initscripts-7.32-1; it requires changes to ifup-ppp,
ifdown-ppp, and ppp-watch.
Comment 13 Bill Nottingham 2003-09-15 01:42:07 EDT
7.33-1, sorry.

Note You need to log in before you can comment on or make changes to this bug.