Bug 978574 - [RFE] Filter messages that can be displayed on the login page
Summary: [RFE] Filter messages that can be displayed on the login page
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon   
(Show other bugs)
Version: 4.0
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: Upstream M3
: 4.0
Assignee: Julie Pichon
QA Contact: Nir Magnezi
URL: https://blueprints.launchpad.net/hori...
Whiteboard:
Keywords: FutureFeature, OtherQA, Triaged
Depends On: 1035879
Blocks: RHOS40RFE
TreeView+ depends on / blocked
 
Reported: 2013-06-26 20:29 UTC by Perry Myers
Modified: 2015-02-15 22:02 UTC (History)
9 users (show)

Fixed In Version: python-django-horizon-2013.2-6.el6ost
Doc Type: Enhancement
Doc Text:
With this update, when a user gets logged out and redirected to the login page, for instance, due to changing their password or the session timing out, a notification message as to why there were redirected to the login page is displayed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-20 00:12:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2013:1859 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement Advisory 2013-12-21 00:01:48 UTC

Comment 1 Julie Pichon 2013-09-06 13:13:42 UTC
3 cases in which a message is displayed on the login page currently:

- After changing your own password using the "Settings" -> "Change password" form
- Session timeout (to test, perhaps set the SESSION_TIMEOUT to a lower number of seconds first in the settings)
- In some cases after receiving an error 401 and redirect (note the easy test case for this one right now is redundant and will be removed in LP#1221716)

Comment 3 Ami Jeain 2013-11-13 14:42:48 UTC
qa_acking, but will probably be tested during Havana test cycle

Comment 5 Julie Pichon 2013-11-28 13:45:24 UTC
There seems to be issues with this patch on Django 1.4, will investigate.

Comment 6 Julie Pichon 2013-11-28 17:59:35 UTC
Never mind the previous comment, it looks like the necessary changes to the login template are being overriden in the openstack-dashboard-theme package (openstack_dashboard_theme/templates/auth/_login.html). The template needs a refresh, I opened bug 1035879 to track this work.

Comment 11 errata-xmlrpc 2013-12-20 00:12:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html


Note You need to log in before you can comment on or make changes to this bug.