Bug 978618 - Accidental broken feature - admin can change usernames
Accidental broken feature - admin can change usernames
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Authentication-Internal (Show other bugs)
development
All All
unspecified Severity high
: ---
: 3.5
Assigned To: Alex Eng
Damian Jansen
:
: 978622 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-26 19:51 EDT by Damian Jansen
Modified: 2015-01-26 18:28 EST (History)
1 user (show)

See Also:
Fixed In Version: 3.5.0-SNAPSHOT (git-server-3.4.1-69-g89bfd75)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-26 18:28:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Damian Jansen 2013-06-26 19:51:39 EDT
Description of problem:
If an administrator changes a user's login username and password in the same action, they will be unable to log in ("Login failed").

Version-Release number of selected component (if applicable):
Dev

How reproducible:
Easily, Always

Steps to Reproduce:
1. Log in as admin
2. Change a user username and password
3. Press Save
4. Logout
5. Attempt to log in as that user with the new credentials

Actual results:
Error, "Login Failed"

Expected results:
User is logged in

Additional info:
Does not seem to occur if the username and password are set in different account save actions. Changing the password again after the account is broken fixes the login.
Comment 1 Damian Jansen 2013-06-27 21:49:04 EDT
Bug was "Changing a user's username and password in the same step breaks their login"

The bug is being able to change a user's username at all.

Make field read-only!
Comment 2 Damian Jansen 2013-06-27 21:51:06 EDT
*** Bug 978622 has been marked as a duplicate of this bug. ***
Comment 3 Alex Eng 2014-05-28 19:30:41 EDT
Pull request:
https://github.com/zanata/zanata-server/pull/473
Comment 4 Damian Jansen 2014-06-11 01:56:44 EDT
Is good.

Note You need to log in before you can comment on or make changes to this bug.