Bug 978622 - No validation on username in Administration user management
No validation on username in Administration user management
Status: CLOSED DUPLICATE of bug 978618
Product: Zanata
Classification: Community
Component: Authentication-Internal (Show other bugs)
development
All All
unspecified Severity medium
: ---
: ---
Assigned To: Isaac Rooskov
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-26 20:22 EDT by Damian Jansen
Modified: 2015-08-06 01:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-27 21:51:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Damian Jansen 2013-06-26 20:22:31 EDT
Description of problem:
The registration form for Zanata has input validation, i.e. restricts to lowercase letters and digits. The Account Details management form does not, and allows the saving of any characters as part of the username.

Version-Release number of selected component (if applicable):
Dev

How reproducible:
Easily, Always

Steps to Reproduce:
1. Click menu More, then Register
2. Enter user+++== in the username field
3. Note the error displayed
4. Log in as an administrator
5. Select menu More, Administration, Manage Users
6. Click Edit on a user
7. Enter user+++== in the username field
8. No validation message
9. Click Save
10. user+++== is saved

Actual results:
Username is accepted, bad characters and all

Expected results:
Username rejected

Additional info:
Comment 1 Damian Jansen 2013-06-26 20:25:28 EDT
It appears that the user cannot log in with this username, changing it back to something acceptable works again.
Comment 2 Damian Jansen 2013-06-27 21:51:06 EDT
Unintended feature, bug is deemed duplicate of 978618.

*** This bug has been marked as a duplicate of bug 978618 ***

Note You need to log in before you can comment on or make changes to this bug.