Bug 978619 - version 3.0 service endpoints fails keystone operations
version 3.0 service endpoints fails keystone operations
Status: CLOSED DUPLICATE of bug 978657
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-keystone (Show other bugs)
3.0
x86_64 Linux
unspecified Severity urgent
: ---
: 4.0
Assigned To: RHOS Maint
Ami Jeain
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-26 19:57 EDT by netops
Modified: 2016-04-26 23:25 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-08 15:38:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description netops 2013-06-26 19:57:42 EDT
Description of problem:

after create v3.0 service endpoints by following the redhat openstack instalaltion documents. with admin account we can not run keystone commands, like 'keystone user-list', etc.

the v3.0 service end points can not be removed with keystone endpoint-delete command neither.

Version-Release number of selected component (if applicable):


How reproducible:

every time.

Steps to Reproduce:
1. follow the document to create v3.0 endpoints.
2. source /root/keystonerc_admin
3. run 'keystone user-list'

Actual results:
Authorization Failed: Unable to communicate with identity service: {"error": {"message": "The resource could not be found.", "code": 404, "title": "Not Found"}}. (HTTP 404)

Expected results:
+----------------------------------+--------+---------+-------+
|                id                |  name  | enabled | email |
+----------------------------------+--------+---------+-------+
| 25f03d4b6e994ed1bd0f36d0a3d40879 | admin  |   True  |       |
| 2ac21fa006ea4d74ab1b20eb5150affa | myself |   True  |       |
+----------------------------------+--------+---------+-------+

Additional info:

remove all the v3.0 endpint entries from table 'keystone.endpoint' fixed the problem.
Comment 2 Alan Pevec 2013-07-08 15:38:50 EDT

*** This bug has been marked as a duplicate of bug 978657 ***

Note You need to log in before you can comment on or make changes to this bug.