Bug 978657 - v3.0 Keystone endpoint should actually be v3.
v3.0 Keystone endpoint should actually be v3.
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: doc-Installation_and_Configuration_Guide (Show other bugs)
3.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Stephen Gordon
ecs-bugs
: Documentation
: 978619 (view as bug list)
Depends On:
Blocks: 1011085
  Show dependency treegraph
 
Reported: 2013-06-26 23:24 EDT by Stephen Gordon
Modified: 2013-09-24 13:56 EDT (History)
4 users (show)

See Also:
Fixed In Version: Red_Hat_OpenStack-Installation_and_Configuration_Guide-3-en-US-3-26
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 15:05:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gordon 2013-06-26 23:24:25 EDT
When creating the v3 keystone endpoint the URL used includes the string "v3.0", in this API version however the minor component (".0") has been dropped. The correct string to denote the endpoint version is "v3".
Comment 1 Stephen Gordon 2013-06-27 09:20:26 EDT
"Creating the Identity Service Endpoint" - ID: 15928 [rev: 472145]

Updated v3.0 -> v3 but still need to answer the question about dual endpoint creation (whether it is required or not).
Comment 2 Stephen Gordon 2013-06-27 09:23:01 EDT
"Defining Regions" - ID: 15915 [rev: 472147]

Also required the v3.0 -> v3 update.
Comment 3 Stephen Gordon 2013-06-30 18:21:43 EDT
(In reply to Stephen Gordon from comment #1)
> "Creating the Identity Service Endpoint" - ID: 15928 [rev: 472145]
> 
> Updated v3.0 -> v3 but still need to answer the question about dual endpoint
> creation (whether it is required or not).

Alan or Adam can you help me out here?
Comment 5 Alan Pevec 2013-07-08 15:38:50 EDT
*** Bug 978619 has been marked as a duplicate of this bug. ***
Comment 6 Alan Pevec 2013-07-08 15:49:00 EDT
> Updated v3.0 -> v3 but still need to answer the question about dual endpoint
> creation (whether it is required or not).

In Grizzly, v3 is still work-in-progress, e.g. authtoken middelware has not been updated to handle v3 tokens, see https://lists.launchpad.net/openstack/msg21673.html

So v3 endpoint not required for the working openstack setup, but it doesn't hurt, but also not very useful (you can use v3 tokens only to talk to the Identity service itself).

I'll leave needinfo on Adam to decide should v3 endpoint stay or be removed from Grizzly docs to avoid confusion.
Comment 8 Stephen Gordon 2013-07-24 15:05:20 EDT
On list discussion indicates current approach is OK.

Note You need to log in before you can comment on or make changes to this bug.