Bug 978778 - quotad: data not taken into consideration for calculation, which got created while quotad was down
quotad: data not taken into consideration for calculation, which got created ...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.1
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: vpshastry
Saurabh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-27 02:50 EDT by Saurabh
Modified: 2016-01-19 01:12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:39:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saurabh 2013-06-27 02:50:35 EDT
Description of problem:
problem here is that the quotad was down,

before it going down I had created a dir and set the limit of 1GB on the dir
Now, after bringing the quotad back
still the quota list does not caculate the data that was created inside the dir, while quotad was down

Infact, even after bringing it back I am able to create more data inside the dir.

Version-Release number of selected component (if applicable):

[root@quota1 ~]# rpm -qa | grep glusterfs
glusterfs-3.4rhs-1.el6rhs.x86_64
glusterfs-fuse-3.4rhs-1.el6rhs.x86_64
glusterfs-server-3.4rhs-1.el6rhs.x86_64

How reproducible:
can be seen this time, as tried out for first time.

Steps to Reproduce:
1. create a volume, start it
2. put some limit on the root of the volume
3. mount the volume using nfs
4. create some data in int
5. gluster volume quota <vol-name> list
6. create a dir in the root of the volume
7. gluster volume quota <vol-name> limit-usage /dir 1GB
8. put quotad down
9. start creating 500MB files inside the dir
10. bring quotad back
11. gluster volume quota <vol-name> list
12. create more data inside the /dir
13. gluster volume quota <vol-name> list

Actual results:

step 11 and 13 fail to collect and calculate the space Used.

[root@quota1 ~]# gluster volume quota dist-rep list
                  Path                   Hard-limit Soft-limit   Used  Available
--------------------------------------------------------------------------------
/                                          100GB       80%      60.3GB  39.7GB
/dir                                         1GB       80%      0Bytes   1.0GB
[root@quota1 ~]# 

[root@rhel6 dir]# ls -l
total 2097152
-rw-r--r--. 1 root root 536870912 Jun 26 11:20 1.1372249725
-rw-r--r--. 1 root root 536870912 Jun 26 11:20 2.1372249815
-rw-r--r--. 1 root root 536870912 Jun 26 11:20 3.1372249822
-rw-r--r--. 1 root root 536870912 Jun 26 11:20 4.1372249833
[root@rhel6 dir]# 
[root@rhel6 dir]# 
[root@rhel6 dir]# dd if=/dev/zero of=$i.$(date +%s) bs=1048576 count=512
512+0 records in
512+0 records out
536870912 bytes (537 MB) copied, 6.78251 s, 79.2 MB/s
[root@rhel6 dir]# ls -l
total 2621440
-rw-r--r--. 1 root root 536870912 Jun 26 11:20 1.1372249725
-rw-r--r--. 1 root root 536870912 Jun 26 11:20 2.1372249815
-rw-r--r--. 1 root root 536870912 Jun 26 11:20 3.1372249822
-rw-r--r--. 1 root root 536870912 Jun 26 11:20 4.1372249833
-rw-r--r--. 1 root root 536870912 Jun 27 04:44 4.1372312495
[root@rhel6 dir]# dd if=/dev/zero of=5.$(date +%s) bs=1048576 count=512
512+0 records in
512+0 records out
536870912 bytes (537 MB) copied, 14.614 s, 36.7 MB/s
[root@rhel6 dir]# du -sh
3.0G    .
[root@rhel6 dir]# du -h .
3.0G    .
[root@rhel6 dir]# ls -l
total 3145728
-rw-r--r--. 1 root root 536870912 Jun 26 11:20 1.1372249725
-rw-r--r--. 1 root root 536870912 Jun 26 11:20 2.1372249815
-rw-r--r--. 1 root root 536870912 Jun 26 11:20 3.1372249822
-rw-r--r--. 1 root root 536870912 Jun 26 11:20 4.1372249833
-rw-r--r--. 1 root root 536870912 Jun 27 04:44 4.1372312495
-rw-r--r--. 1 root root 536870912 Jun 27 04:45 5.1372312511
[root@rhel6 dir]# 

[root@quota1 ~]# gluster volume quota dist-rep list
                  Path                   Hard-limit Soft-limit   Used  Available
--------------------------------------------------------------------------------
/                                          100GB       80%      61.2GB  38.8GB
/dir                                         1GB       80%      0Bytes   1.0GB



Expected results:
The quota implementation should take care of this scenario

Additional info:
quotad went down because of BZ 978333
Comment 5 Scott Haines 2013-09-23 18:39:52 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 6 Scott Haines 2013-09-23 18:43:49 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.