Bug 978782 - firefox 22 tries to use user configured proxy even if system proxy settings is selected
firefox 22 tries to use user configured proxy even if system proxy settings i...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
19
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Horak
Fedora Extras Quality Assurance
:
Depends On: 981166 1005893
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-27 03:00 EDT by Mamoru TASAKA
Modified: 2013-09-09 11:40 EDT (History)
9 users (show)

See Also:
Fixed In Version: xulrunner-22.0-4.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-12 21:48:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 817533 None None None Never

  None (edit)
Description Mamoru TASAKA 2013-06-27 03:00:53 EDT
Description of problem:
With firefox/xulrunner 22.0, it seems that every http://
page cannot be loaded with unknown proxy error


Version-Release number of selected component (if applicable):
xulrunner-22.0-1.fc19
firefox-22.0-1.fc19

How reproducible:
100%

Steps to Reproduce:
1. Update to xulrunner-22.0-1.fc19, firefox-22.0-1.fc19
2. launch firefox
3. open http:// page, like http://www.google.co.jp/

Actual results:

The proxy server is refusing connections
Firefox is configured to use a proxy server that is refusing connections.
  Check the proxy settings to make sure that they are correct.
  Contact your network administrator to make sure the proxy server is
    working.

Expected results:
No issue

Additional info:
* No issue with firefox/xulrunner 21.0
  (I once downgraded to firefox 21.0 and there is no problem)
* https:// seems no problem with firefox 22.0
* http://, https:// have no problem with midori-0.5.0-1.fc19
Comment 1 Mamoru TASAKA 2013-06-27 03:26:18 EDT
Creating new account and using firefox 22.0 seems no problem.
Comment 2 Martin Stransky 2013-06-27 07:48:45 EDT
I'm unable to reproduce to...so a new profile fixes that right?
Comment 3 Mamoru TASAKA 2013-06-27 10:28:23 EDT
What I mean is that when I create new account and launch firefox 22.0 with that account (i.e., with ~/.mozilla all deleted) it seems to work - however it is not I want.
Comment 4 Martin Stransky 2013-06-27 10:30:55 EDT
And if you create a new profile and run it? (by firefox -ProfileManager)
Comment 5 Mamoru TASAKA 2013-06-27 11:05:53 EDT
With a new profile it seems to work - and it is not I want.
Comment 6 Mamoru TASAKA 2013-06-27 11:13:25 EDT
It seems that with "problematic" profile, when I choose
"Auto-detect proxy settings for this network" http:// pages
can be loaded.
The default seems "Use system proxy settings" and with that I see
problems with http:// pages.
Comment 7 Mamoru TASAKA 2013-06-27 11:24:38 EDT
I don't know if the following information is useful, however:

$ gsettings list-recursively org.gnome.system.proxy
org.gnome.system.proxy autoconfig-url ''
org.gnome.system.proxy ignore-hosts ['localhost', '127.0.0.0/8', '::1']
org.gnome.system.proxy mode 'none'
org.gnome.system.proxy use-same-proxy true
org.gnome.system.proxy.ftp host ''
org.gnome.system.proxy.ftp port 0
org.gnome.system.proxy.http authentication-password ''
org.gnome.system.proxy.http authentication-user ''
org.gnome.system.proxy.http enabled false
org.gnome.system.proxy.http host ''
org.gnome.system.proxy.http port 8080
org.gnome.system.proxy.http use-authentication false
org.gnome.system.proxy.https host ''
org.gnome.system.proxy.https port 0
org.gnome.system.proxy.socks host ''
org.gnome.system.proxy.socks port 0
Comment 9 Jan Horak 2013-06-28 04:05:16 EDT
(In reply to Mamoru TASAKA from comment #7)
> I don't know if the following information is useful, however:
> 
> $ gsettings list-recursively org.gnome.system.proxy
> org.gnome.system.proxy autoconfig-url ''
> org.gnome.system.proxy ignore-hosts ['localhost', '127.0.0.0/8', '::1']
> org.gnome.system.proxy mode 'none'
> org.gnome.system.proxy use-same-proxy true
> org.gnome.system.proxy.ftp host ''
> org.gnome.system.proxy.ftp port 0
> org.gnome.system.proxy.http authentication-password ''
> org.gnome.system.proxy.http authentication-user ''
> org.gnome.system.proxy.http enabled false
> org.gnome.system.proxy.http host ''
> org.gnome.system.proxy.http port 8080
> org.gnome.system.proxy.http use-authentication false
> org.gnome.system.proxy.https host ''
> org.gnome.system.proxy.https port 0
> org.gnome.system.proxy.socks host ''
> org.gnome.system.proxy.socks port 0
I miss proxy host address in your settings, at least 'org.gnome.system.proxy.http host' or 'org.gnome.system.proxy.socks host' should be set to proxy hostname or ip address.
Comment 10 Mamoru TASAKA 2013-06-28 04:12:39 EDT
But another F-19 machine where firefox 22 is working seems to have the same settings:

On working machine:
$ gsettings list-recursively org.gnome.system.proxy
org.gnome.system.proxy autoconfig-url ''
org.gnome.system.proxy ignore-hosts ['localhost', '127.0.0.0/8', '::1']
org.gnome.system.proxy mode 'none'
org.gnome.system.proxy use-same-proxy true
org.gnome.system.proxy.ftp host ''
org.gnome.system.proxy.ftp port 0
org.gnome.system.proxy.http authentication-password ''
org.gnome.system.proxy.http authentication-user ''
org.gnome.system.proxy.http enabled false
org.gnome.system.proxy.http host ''
org.gnome.system.proxy.http port 8080
org.gnome.system.proxy.http use-authentication false
org.gnome.system.proxy.https host ''
org.gnome.system.proxy.https port 0
org.gnome.system.proxy.socks host ''
org.gnome.system.proxy.socks port 0
[mtasaka@localhost ~]$ rpm -q firefox
firefox-22.0-1.fc19.i686

By the way, googling shows that some other people seems to be facing with the same issue like:
http://forums.mozillazine.org/viewtopic.php?f=38&t=2721971
Comment 11 Mamoru TASAKA 2013-06-28 04:41:08 EDT
Okay, now I am able to reproduce this issue with newly created profile.

Step to reproduce:
* Launch with firefox -ProfileManager , create new profile, and launch
  firefox with that (new) profile
* Go Preferences -> Advanced -> Network -> Connection -> Settings
* Once choose "Manual proxy configuration", set random http proxy, change port
  (like HTTP Proxy: aaaaaa Port: 8080).
* Then choose *again* "Use system proxy settings"
* Click OK
* Now open some http:// page

Then firefox 22 says
Unable to find the proxy server
  Firefox is configured to use a proxy server that can't be found.
Comment 12 Jan Horak 2013-06-28 06:05:20 EDT
Okay, on your original profile, which works bad, what's your Firefox proxy settings (Auto-detect/Use System proxy/Manual proxy config)? 

If you use 'Use system proxy settings' you have to set your proxy setting in gnome-control-center/Network/Network proxy most likely to Manual and fill in your proxy server and port.

Or you can set proxy in Firefox by choosing 'Manual proxy' and filling proxy server and port there.
Comment 13 Chris Rankin 2013-06-29 12:47:29 EDT
I have also just experienced this problem after upgrading to Firefox 22. In my case, I had old "Manual HTTP Proxy" values configured, *but not selected*! Firefox was actually supposed to be using the "System Proxy" - and this system doesn't have a proxy of course.

Reconfiguring Firefox 22 to have "No Proxy" fixed things.

Removing the unselected and greyed out values from the Manual HTTP Proxy and then switching *back* to using the "System Proxy" again also fixed things.
Comment 14 Mamoru TASAKA 2013-06-30 20:14:36 EDT
(In reply to Jan Horak from comment #12)
> Okay, on your original profile, which works bad, what's your Firefox proxy
> settings (Auto-detect/Use System proxy/Manual proxy config)? 

Use System proxy

> If you use 'Use system proxy settings' you have to set your proxy setting in
> gnome-control-center/Network/Network proxy most likely to Manual and fill in
> your proxy server and port.

No system proxy on my global proxy setting. So firefox 22 should be able
to open http:// pages as before, as the same as comment 13 from Chris.

> Or you can set proxy in Firefox by choosing 'Manual proxy' and filling proxy
> server and port there.

Again this is not I want. I choose default "Use system proxy settings" and
there is actually no proxy on global settings.
Comment 15 Jan Horak 2013-07-01 08:54:44 EDT
Finally I can reproduce this problem, thanks for clarification on comment 13. This issue is going to be fixed in Firefox 23. We'll attach the patch from mozbz#817533 also to Firefox 22 on Fedoras. Thanks for the report.
Comment 16 Fedora Update System 2013-07-02 05:00:47 EDT
xulrunner-22.0-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/xulrunner-22.0-4.fc18
Comment 17 Fedora Update System 2013-07-02 05:01:05 EDT
xulrunner-22.0-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xulrunner-22.0-4.fc17
Comment 18 Fedora Update System 2013-07-02 05:01:16 EDT
xulrunner-22.0-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/xulrunner-22.0-4.fc19
Comment 19 Fedora Update System 2013-07-02 21:38:04 EDT
Package xulrunner-22.0-4.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xulrunner-22.0-4.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12153/xulrunner-22.0-4.fc17
then log in and leave karma (feedback).
Comment 20 Account closed by the user 2013-07-03 16:18:06 EDT
(In reply to Fedora Update System from comment #18)

> xulrunner-22.0-4.fc19 has been submitted as an update for Fedora 19.
> https://admin.fedoraproject.org/updates/xulrunner-22.0-4.fc19

it's broken.

---> Package xulrunner.x86_64 0:22.0-1.fc19 will be updated
---> Package xulrunner.x86_64 0:22.0-4.fc19 will be an update
--> Processing Dependency: nspr >= 4.10.0 for package: xulrunner-22.0-4.fc19.x86_64

Packages skipped because of dependency problems:
    xulrunner-22.0-4.fc19.x86_64 from updates-testing
Comment 21 Elio Maldonado Batiz 2013-07-05 11:06:34 EDT
I pushed nspr-4.10.0-3.fc19 to the Fedora 19 testing repository, it should now be available on updates-testing. We think will help with this issue. Update it with: # su -c 'yum update --enablerepo=updates-testing nspr-4.10.0-3.fc19'
Please test it and give it Karma so I can push it to stable. Thanks, -Elio
Comment 22 Elio Maldonado Batiz 2013-07-05 11:07:40 EDT
https://admin.fedoraproject.org/updates/nspr-4.10.0-3.fc19
Comment 23 Mark Harfouche 2013-07-09 02:13:43 EDT
Just an FYI, the patches submitted for Firefox 22 didn't seem to help, but aparently it is fixed in Firefox 23

see https://bugzilla.mozilla.org/show_bug.cgi?id=817533#c19
Comment 24 Fedora Update System 2013-07-10 03:42:06 EDT
xulrunner-22.0-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/xulrunner-22.0-4.fc19
Comment 25 Fedora Update System 2013-07-12 21:48:58 EDT
xulrunner-22.0-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 26 Fedora Update System 2013-07-24 20:50:22 EDT
xulrunner-22.0-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 27 Mark Harfouche 2013-07-24 21:30:29 EDT
Seems to be fixed in F19. Thanks :D

Note You need to log in before you can comment on or make changes to this bug.