Bug 981166 - The xulrunner required version of nspr cannot be found
The xulrunner required version of nspr cannot be found
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: nspr (Show other bugs)
19
Unspecified Linux
urgent Severity urgent
: ---
: ---
Assigned To: Elio Maldonado Batiz
Fedora Extras Quality Assurance
:
: 981164 (view as bug list)
Depends On:
Blocks: 978782 1005893
  Show dependency treegraph
 
Reported: 2013-07-04 03:30 EDT by Thomas Citharel
Modified: 2013-09-09 11:40 EDT (History)
9 users (show)

See Also:
Fixed In Version: nspr-4.10.0-3.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1005893 (view as bug list)
Environment:
Last Closed: 2013-07-06 21:37:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Citharel 2013-07-04 03:30:42 EDT
Description of problem:
When trying to upgrade with yum, it says xulrunner requires the nspr >= 4.10.0 version, while the versions are currently written like nspr-4.10-2. So my installed version is not detected.

Version-Release number of selected component (if applicable):


How reproducible:

Steps to Reproduce:
1. yum update
2.
3.

Actual results:
(...)
Erreur : Paquet : xulrunner-22.0-4.fc19.x86_64 (updates-testing)
             Requiert : nspr >= 4.10.0
             Installé  : nspr-4.10-2.fc19.i686 (@updates)
                 nspr = 4.10-2.fc19
             Disponible : nspr-4.9.6-1.fc19.i686 (fedora)
                 nspr = 4.9.6-1.fc19
 Vous pouvez essayer d'utiliser --skip-broken pour contourner le problème
 Vous pouvez essayer d'exécuter : rpm -Va --nofiles --nodigest


Expected results:
Installation going on.

Additional info:
Just modifying the xulrunner-22.0-4.fc19.x86_64 package SPEC file currently in updates-testing should do it.
Comment 1 Thomas Citharel 2013-07-04 03:40:00 EDT
*** Bug 981164 has been marked as a duplicate of this bug. ***
Comment 2 Jan Horak 2013-07-04 03:42:15 EDT
Elio, can you please look into it? It seems we're hitting the same problem with nspr vs nspr pkgconfig version mismatch like in rawhide. Thanks.
Comment 3 Elio Maldonado Batiz 2013-07-04 11:53:56 EDT
Yes, this is the same problem as we faced in Rawhide and the same fix applies.

Here is a slightly edited copy of the good explanation Kai provided to our collegues upstream:

The issue is related to pkg-config, which reads our config/nspr.pc file.

The file has a line: 
Version: @MOD_MAJOR_VERSION@.@MOD_MINOR_VERSION@.@MOD_PATCH_VERSION@

so the pkg-config system always includes the "patch" version number,
even if it's zero.

Because our build automation uses rules based on the reported version number,
our system package versions follow the versions shown in the tar archive. 
Because the tar archive excludes the patch version, that  resulted in a 
package version without the patch version, which resulted in an unsatisfied lookup, 
if software looks for the version reported by pkg-config.

tar archive: nspr-4.10
package version: nspr-4.10
dependency resolver: looking for nspr-4.10.0

because nspr-4.10 < nspr.4.10.0, the dependency resolution failed.

From this update onwards we include the patch version number in the
package version number. Instead of nspr-4.10 we do nspr-4.10.0
The release tarballs now match the officially used version number.
Comment 4 Fedora Update System 2013-07-04 12:11:58 EDT
nspr-4.10.0-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/nspr-4.10.0-3.fc19
Comment 5 Fedora Update System 2013-07-04 13:08:37 EDT
nspr-4.10.0-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/nspr-4.10.0-3.fc18
Comment 6 Fedora Update System 2013-07-04 13:10:42 EDT
nspr-4.10.0-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/nspr-4.10.0-3.fc17
Comment 7 Fedora Update System 2013-07-04 22:11:48 EDT
Package nspr-4.10.0-3.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing nspr-4.10.0-3.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12367/nspr-4.10.0-3.fc18
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-07-06 21:37:40 EDT
nspr-4.10.0-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2013-07-15 21:28:17 EDT
nspr-4.10.0-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2013-07-22 21:04:59 EDT
nspr-4.10.0-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.