Bug 978790 - anaconda kickstart requires manual network intervention with single CPU
anaconda kickstart requires manual network intervention with single CPU
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-27 03:17 EDT by Bruce Jerrick
Modified: 2014-02-21 17:05 EST (History)
7 users (show)

See Also:
Fixed In Version: anaconda-20.25.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-21 17:05:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruce Jerrick 2013-06-27 03:17:36 EDT
Description of problem:
(First off, let me say that I don't regard this as a probem that is destined
to be fixed, due to the unusual circumstances, outlined below.)

When I run what should be a hands-off kickstart installation, the network
spoke pops up and requires a manual "Continue" to proceed.  (About 10-20%
of the time, it doesn't show, but instead the "Begin Installation" on the
hub window is activated, and requires clicking to proceed.)

This happens on a VMware virtual machine (the network interfaces appear as
ens33 and ens37, i.e., hardwired Ethernet).  This always happened while the
VM was configured with one single-core CPU.  But when I configured it with
one dual-core CPU, the problem went away -- anaconda immediately started
"Preparing to install", as it should.

As I said, I don't expect a resolution of this.  Where else but in a
virtual machine can you get a single CPU these days?

Version-Release number of selected component:
anaconda-19.30.8-1.fc19.x86_64

How reproducible:
Near 100%

Additional info:
Someone once said "Threads are evil".  I have never argued the point.
Comment 1 Chris Lumens 2013-08-21 17:11:38 EDT
Yeah, I have definitely seen this before too.
Comment 2 Chris Lumens 2014-02-21 17:05:50 EST
This should be fixed by the patch for bug 1025347.  Thanks for the report.

Note You need to log in before you can comment on or make changes to this bug.