Bug 979042 - Slow download of packages
Slow download of packages
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
Unspecified Unspecified
low Severity unspecified
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-27 09:25 EDT by Zdenek Kabelac
Modified: 2014-09-30 19:41 EDT (History)
4 users (show)

See Also:
Fixed In Version: dnf-0.3.11-1.git7d717c7.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-16 19:05:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zdenek Kabelac 2013-06-27 09:25:06 EDT
Description of problem:

I've tested dnf on my Rawhide installation when 'yum upgrade --skip-broken' was unable to resolve dependencies and it has ignored many package from upgrade transaction (Bug863044).  While the transaction has been nicely resolved and 3/4 of package has been properly marked for upgrade, the download part it self has been pretty slow compared with 'yum' performance here.
My DSL provider has pretty decent connection speed and individual package download rate was above 1MB/s - however between the download of each package there was quite noticeable delay in range of 2-3 seconds (which sums up, when >100 packages is upgraded)


Version-Release number of selected component (if applicable):
dnf-0.3.8-2.git85524ae.fc20.noarch

How reproducible:


Steps to Reproduce:
1. dnf upgrade
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Ales Kozumplik 2013-06-27 09:38:17 EDT
I saw this too, some digging needs to take place to decide whether this is a librepo issue or whether we do something strange ourselves.

Low prio at this point.
Comment 2 Ales Kozumplik 2013-06-27 10:11:17 EDT
The observed delay before download start is due to how the progress bar is implemented: it is waiting for librepo to tell us the total package size, which for some involved reasons can not do so right away, even though the download has already started. As zpavlas pointed out we should be able to deduce this information from the available metadata instead.

Assigning to zpavlas who already did patching in this area.

Notwithstanding the console output the total download time is probably going to be larger than in the current Yum versions due to the missing support of parallel package downloads (bug 909744).
Comment 3 Ales Kozumplik 2013-07-24 10:38:18 EDT
(In reply to Ales Kozumplik from comment #2)
> The observed delay before download start is due to how the progress bar is
> implemented: it is waiting for librepo to tell us the total package size,

Actually, this is only a part of the problem. As I found out today, most time is lost because DNF creates an extra librepo handle for each package download and these need to sync the mirrorlist first to know the real repo URL ("baseurl"). And that takes most of the extra time.
Comment 4 Ales Kozumplik 2013-07-25 08:51:30 EDT
Fixed the mirrorlist syncing (commit fecb703, will be in dnf-0.3.11), on a fast network this speeds up download of each package by approx. 1.5s. I consider this resolved then, and opened bug 988377 to deal with the progress bar dealy.
Comment 5 Fedora Update System 2013-08-13 06:47:16 EDT
dnf-0.3.11-1.git7d717c7.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/dnf-0.3.11-1.git7d717c7.fc19
Comment 6 Fedora Update System 2013-08-14 22:33:42 EDT
Package dnf-0.3.11-1.git7d717c7.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-0.3.11-1.git7d717c7.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14693/dnf-0.3.11-1.git7d717c7.fc19
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-08-16 19:05:37 EDT
dnf-0.3.11-1.git7d717c7.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.