Bug 988377 - delay before progress bar appears on each package download
delay before progress bar appears on each package download
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Zdeněk Pavlas
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-25 08:50 EDT by Ales Kozumplik
Modified: 2014-02-02 17:29 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-18 09:40:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ales Kozumplik 2013-07-25 08:50:17 EDT
This is the originally suspected and still present issue from bug 979042, users complain that package download takes long time. While the original bug fixed the underlying issue there still appears to be a little pause before each download starts. The observed delay is due to how the progress bar is implemented: it is waiting for librepo to tell us the total package size, which for some involved reasons can not do so right away, even though the download has already started. 

As zpavlas pointed out we should be able to deduce this information from the available metadata instead, assigning to Zdenek.
Comment 1 Zdeněk Pavlas 2013-10-18 09:40:00 EDT
This appears to be fixed in the new downloader, the progress bar is initialized much sooner.

Note You need to log in before you can comment on or make changes to this bug.