Bug 979098 - Multiple fixes for Hibernate unique keys and foreign keys in ORM 4.2.0.Final
Multiple fixes for Hibernate unique keys and foreign keys in ORM 4.2.0.Final
Status: CLOSED DUPLICATE of bug 981720
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Hibernate (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity high
: ---
: EAP 6.1.1
Assigned To: Brett Meyer
:
Depends On:
Blocks: 979103
  Show dependency treegraph
 
Reported: 2013-06-27 11:16 EDT by Brett Meyer
Modified: 2015-09-01 00:00 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 979103 (view as bug list)
Environment:
Last Closed: 2013-07-29 11:37:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brett Meyer 2013-06-27 11:16:16 EDT
Hibernate 4.2.0.Final (EAP 6.1.0) included changes to how unique keys and foreign keys were generated (both default to using constraints in "alter table" statements).  Multiple issues were found and fixed in commits spanning 4.2.1.Final to 4.2.3.Final.

This is fairly high priority and should be considered for EAP 6.1.1.  It may affect anyone using schema generation and un-named unique or foreign keys.

https://hibernate.atlassian.net/browse/HHH-1904
https://hibernate.atlassian.net/browse/HHH-8092
https://hibernate.atlassian.net/browse/HHH-8178
https://hibernate.atlassian.net/browse/HHH-8162
https://hibernate.atlassian.net/browse/HHH-8217
https://hibernate.atlassian.net/browse/HHH-8269
https://hibernate.atlassian.net/browse/HHH-8273
https://hibernate.atlassian.net/browse/HHH-8275
Comment 1 Brett Meyer 2013-06-27 11:18:08 EDT
Note that there may be some concerns about backward compatability with the fixes.  They do change the strategy used for automatic generation of constraint names.  However, we're specifically fixing issues where this generation was not deterministic in 4.2.0.Final, so it's a moot point.
Comment 7 Carlo de Wolf 2013-07-29 11:37:25 EDT

*** This bug has been marked as a duplicate of bug 981720 ***
Comment 8 Rostislav Svoboda 2013-08-28 04:56:38 EDT
Removing flags (not to see this bz in ACK_VIEW)

Note You need to log in before you can comment on or make changes to this bug.