Bug 981720 - Upgrade to Hibernate 4.2.0.SP1
Upgrade to Hibernate 4.2.0.SP1
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Hibernate (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ER3
: EAP 6.1.1
Assigned To: Dave Stahl
Russell Dickenson
:
: 962421 979098 (view as bug list)
Depends On:
Blocks: 979103
  Show dependency treegraph
 
Reported: 2013-07-05 11:12 EDT by Dave Stahl
Modified: 2015-11-08 20:10 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
HHH-6813 https://hibernate.atlassian.net/browse/HHH-6813 Having an @Id @OneToOne (derived primary key from a foreign key) causes NullPointerExceptions during any query ----------------------------------------------- (All of the following fixes compose a near complete re-write of how Hibernate generates names for unique, foreign, and index constraints that are not explicitly named in mappings. The set should be taken holistically, rather than individually -- most iteratively build on each other.) HHH-1904 (superseded), HHH-8217, HHH-8269 https://hibernate.atlassian.net/browse/HHH-1904 https://hibernate.atlassian.net/browse/HHH-8217 https://hibernate.atlassian.net/browse/HHH-8269 To ensure a maximum identifier length, generate all non-named constraint names by hashing a concatenation of the table name and an alphabetical ordering of column names. HHH-8217 supersedes HHH-1904 with the correct approach. HHH-8092, HHH-8162 https://hibernate.atlassian.net/browse/HHH-8092 https://hibernate.atlassian.net/browse/HHH-8162 The pre-existance of unique constraints cannot be easily/consistently checked within JDBC. Methods for foreign keys and indexes exist, but uniques would require very dialect-specific functions to be used. Instead, allow unique constraint handling during a schema update to be configurable: completely ignore uniques altogether or attempt to (re-)create the constraints and ignore any errors (but include a warning log). HHH-8178 https://hibernate.atlassian.net/browse/HHH-8178 The internal processing of natural keys was corrected to ensure all of its columns were going into a single unique constraint. The hashed name changes, above, had broken it. HHH-8275 https://hibernate.atlassian.net/browse/HHH-8275 Union-subclass inheritance mappings were incorrectly using the parent table name in the unique constraint "alter table" statement, instead of the sub-table. HHH-8273 https://hibernate.atlassian.net/browse/HHH-8273 Corrected "unique-key" documentation to reflect all above changes. -----------------------------------------------
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-16 16:23:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Stahl 2013-07-05 11:12:04 EDT
Upgrade Hibernate version to 4.2.0.SP1 for EAP 6.1.1
Comment 1 Dave Stahl 2013-07-08 15:05:54 EDT
PR - https://github.com/jbossas/jboss-eap/pull/225
Comment 2 Scott Marlow 2013-07-08 15:11:53 EDT
reassigned to Dave Stahl since he created the PR
Comment 3 Zbyněk Roubalík 2013-07-22 08:08:53 EDT
Verified on EAP 6.1.1.ER3
Comment 4 Carlo de Wolf 2013-07-29 11:37:26 EDT
*** Bug 979098 has been marked as a duplicate of this bug. ***
Comment 7 Martin Simka 2013-08-29 10:09:05 EDT
@Brett could you prepare text for release notes? This upgrade fixes several issues
Comment 8 Brett Meyer 2013-08-29 14:01:02 EDT
*** Bug 962421 has been marked as a duplicate of this bug. ***
Comment 9 Brett Meyer 2013-08-29 14:50:11 EDT
Rough draft docs for all fixes added.
Comment 10 Brett Meyer 2013-08-29 21:13:46 EDT
Russell, in light of the email discussion, was this route incorrect?  It's a bit of an odd case due to processes getting jumbled up in this release.  The bug fixes were closed and marked as duplicates of this component upgrade ticket (long story).

Note You need to log in before you can comment on or make changes to this bug.