Bug 979716 - ADMIN & USER have same permissions
ADMIN & USER have same permissions
Status: CLOSED INSUFFICIENT_DATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: doc-Installation_and_Configuration_Guide (Show other bugs)
3.0
x86_64 Unspecified
medium Severity medium
: ---
: 4.0
Assigned To: RHOS Documentation Team
ecs-bugs
: Documentation, Triaged
Depends On:
Blocks: 1011085
  Show dependency treegraph
 
Reported: 2013-06-29 15:46 EDT by admin
Modified: 2013-09-24 13:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Build: CSProcessor Builder Version 1.10 Build Name: 15807, Installation and Configuration Guide-3-1 Build Date: 24-06-2013 11:15:28 Topic ID: 15919-463367 [Latest]
Last Closed: 2013-08-06 11:05:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description admin 2013-06-29 15:46:39 EDT
Title: Validating the Identity Service Installation

Describe the issue: I followed the guide to the letter and I receive something different in this step than the guide would have me expect.

After issuing "source ~/keystone_admin" and running "keystone user-list" I see the users, but when I run "source ~/keystone_user" and then "keystone user-list" I still see the list of users.

Moreover, I get this when I run "keystone get-token":

"WARNING: Bypassing authentication using a token & endpoint (authentication credentials are being ignored).
Configuration error: Client configured to run without a service catalog. Run the client using --os-auth-url or OS_AUTH_URL, instead of --os-endpoint or OS_SERVICE_ENDPOINT, for example."


Suggestions for improvement: Add this information to the guide if this is normal or edit it so that it is more clear or includes this situation.

Additional information:
Comment 2 Stephen Gordon 2013-07-04 16:50:18 EDT
Hi,

The procedure you primarily seem to be referring to ("5.8. Creating a Regular User Account") appears at:

https://access.redhat.com/site/documentation/en-US/Red_Hat_OpenStack/3/html/Installation_and_Configuration_Guide/Creating_User_Accounts1.html

When you ran `keystone get-token` was the SERVICE_TOKEN environment from the previous procedure still set? Can you also confirm with `keystone user-list` and `keystone user-role-list` that the "regular" user is in its own tenant, and not the admin tenant, as per the procedure?

Thanks!

Steve

Note You need to log in before you can comment on or make changes to this bug.