Bug 979871 - Uploaded topics don't take on section title
Uploaded topics don't take on section title
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: Web-UI (Show other bugs)
1.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 1.2
Assigned To: Lee Newson
:
: 1012731 (view as bug list)
Depends On: 1012187
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-01 00:26 EDT by Matthew Casperson
Modified: 2014-08-04 18:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-17 19:49:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Casperson 2013-07-01 00:26:14 EDT
Need to scan uploaded topics for valid XML, and if it is extract the section title as the new topics title.
Comment 1 Lee Newson 2013-09-26 23:33:44 EDT
*** Bug 1012731 has been marked as a duplicate of this bug. ***
Comment 2 Lee Newson 2013-09-26 23:37:52 EDT
Moving this back to new since it hasn't had any work done on it.
Comment 3 Lee Newson 2013-10-09 01:42:38 EDT
Fixed in build 201310091540

Updated the UI so it won't set the title any more. This means that thanks to BZ#1012187 the title will be picked out of the XML on the server.
Comment 5 Matthew Casperson 2013-10-15 01:51:36 EDT
Uploading a file with invalid XML has some issues.
Comment 6 Matthew Casperson 2013-10-15 23:00:19 EDT
The xml title setting is now handled on the client in much the same way as it is set on the server. If the file being uploaded is valid xml with a <section> and a <title> directly under it, the title is extracted and saved as the topic title.

Otherwise a generic title is added so the file can still be uploaded.

Note You need to log in before you can comment on or make changes to this bug.