Bug 98013 - XFree86-4.2.1-13.73.3 and 4.2.1-20 requires pam-devel
XFree86-4.2.1-13.73.3 and 4.2.1-20 requires pam-devel
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-25 10:55 EDT by Pytela, Zdenek
Modified: 2007-04-18 12:55 EDT (History)
2 users (show)

See Also:
Fixed In Version: 4.2.1-21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-28 02:26:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pytela, Zdenek 2003-06-25 10:55:53 EDT
Description of problem:
New XFree86 requires development package pam-devel.

Version-Release number of selected component (if applicable):
4.2.1-13.73.3

How reproducible:
always

Steps to Reproduce:
1. rpm -Fvh XFree86-*
2.
3.
    
Actual results:
pam-devel is needed by XFree86-4.2.1-13.73.3

Expected results:
<nothing but hashes>

Additional info:
Comment 1 Nitin Dahyabhai 2003-06-25 17:36:53 EDT
Same thing on RHL8.0 with 4.2.1-20, and is the -xf86cfg subpackage just gone?
Comment 2 Mike A. Harris 2003-06-28 02:06:56 EDT
Indeed.  Looks like a bad Requires line.

Requires: pam-devel

should be:

Requires: pam

I'll fix it internally in case there ends up being further erratum in the
future, but it isn't itself worthy of another XFree86 update for one small
issue.
Comment 3 Mike A. Harris 2003-06-28 02:26:07 EDT
This is now fixed in 4.2.1-21, which will be released as erratum for Red Hat
Linux 8.0 very soon due to another more serious issue reported in bug #98082
which requires an immediate fix due to the massive package sizes.

Since the src.rpm is now shared between Red Hat Linux 7.3 and 8.0, I pull off
8.0 when doing erratum, so any future 7.3 updates that are warranted will
automatically get this fix as well, so I'm closing this issue as resolved
in ERRATA for Red Hat Linux 8.0 for now even though it's reported against
7.3.

Note You need to log in before you can comment on or make changes to this bug.