Bug 98082 - Package compiled with debug symbols enabled
Package compiled with debug symbols enabled
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
: 98240 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-26 05:59 EDT by Maciej Żenczykowski
Modified: 2007-04-18 12:55 EDT (History)
4 users (show)

See Also:
Fixed In Version: 4.2.1-21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-28 02:29:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Maciej Żenczykowski 2003-06-26 05:59:03 EDT
Description of problem:
The following packages are huge:
XFree86-4.2.1-20 - 70 MB
XFree86-devel-4.2.1-20 - 40 MB

the previous versions were decent sized
XFree86-4.2.0-72.i386.rpm - 11MB
XFree86-devel-4.2.0-72.i386.rpm - 5MB

They seem to be compiled with debugging symbols enabled, XFree86 startup log
messages contain at every step:
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
Not loading .debug_abbrev
Not loading .debug_info
Not loading .rel.debug_info
Not loading .debug_line
...tons more...

Besides this startup time is slightly slower than before (I'm not sure if this
is related...)

Version-Release number of selected component (if applicable):
XFree86-4.2.1-20 XFree86-devel-4.2.1-20

How reproducible:
Always

Steps to Reproduce:
1. download'n'install'n'run

Actual Results:  Disk space used :)

Expected Results:  Less disk space used ;)

Additional info:

I'd classify this as a 'severe memory (disk space) leak'
Comment 1 Mark Wilkinson 2003-06-26 08:12:18 EDT
The binaries aren't stripped, so the an upgrade chews a significant amount of
disk space. Comment added so people who search for XFree86 and strip will
(hopefully) find this bug.
Comment 2 Mike A. Harris 2003-06-28 02:29:18 EDT
Ugh.  This problem occured due to a buildsystem glitch that happened a while
ago which also affected various other errata in progress at the time, in
particular KDE.  The buildsystem was adding '-g' to RPM_OPT_FLAGS, which
caused X to be compiled with gobs of debugging info which did not subsequently
get stripped.  This got missed by us because the XFree86 packages had been
tested prior to us being aware of the problem.

A simple rebuild through our buildsystem will fix this issue, and we'll be
releasing new erratum very soon for this problem due to the huge file sizes
and disk space requirements it creates.  I've also fixed bug #98013 which
was just reported as well.

Closing as ERRATA 4.2.1-21 (soon to be released)
Comment 3 Carlos Rodrigues 2003-06-28 17:41:14 EDT
*** Bug 98240 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.