Bug 980228 - Filing SELinux AVCs (and probably anything) against Rawhide is broken, claims to report bug "-1" or "4294967295"
Filing SELinux AVCs (and probably anything) against Rawhide is broken, claims...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libreport (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Jakub Filak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-01 15:15 EDT by Adam Williamson
Modified: 2016-11-30 19:44 EST (History)
8 users (show)

See Also:
Fixed In Version: libreport-2.1.5-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-08 11:00:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2013-07-01 15:15:20 EDT
I just tried to report an SELinux AVC via the SELinux Troubleshooter in current Rawhide. Here's the output:

--- Running report_Bugzilla ---
Logging into Bugzilla at https://bugzilla.redhat.com
Checking for duplicates
Creating a new bug
Adding attachments to bug -1
Logging out
Status: NEW https://bugzilla.redhat.com/show_bug.cgi?id=4294967295

clearly, something somewhere is badly wrong. :) Neither bug -1 nor bug 4294967295 actually exists. I checked. (Though we should *really* set up some Easter Egg bug reports for obvious special numbers...;>)

'Urgent' as this hampers a lot of Rawhide testing.
Comment 1 Jakub Filak 2013-07-02 04:03:32 EDT
Thank you for the report! The reporting on Rawhide is still broken and the root cause is bug #958933.

Anyway, you have found another bug and I have submitted a patch for it:
https://lists.fedorahosted.org/pipermail/crash-catcher/2013-July/004909.html

Thank you!
Comment 2 Jakub Filak 2013-07-02 05:41:32 EDT
Fixed in upstream git:

commit ed04964627f465d8bd18297286abf3a3d3e922ce
Author: Jakub Filak <jfilak@redhat.com>
Date:   Tue Jul 2 09:55:53 2013 +0200

    rhbz: test xmlrpc env for errors in abrt_xmlrpc_call_params()
    
    Closes rhbz#980228
    
    Signed-off-by: Jakub Filak <jfilak@redhat.com>
    Signed-off-by: Denys Vlasenko <dvlasenk@redhat.com>

commit 0b4ef1e6f83e7f4a2e0262d0c2dc6280cfbd72a0
Author: Jakub Filak <jfilak@redhat.com>
Date:   Tue Jul 2 09:55:52 2013 +0200

    rhbz: test rhbz_new_bug() return value for errors
    
    Related to rhbz#980228
    
    Signed-off-by: Jakub Filak <jfilak@redhat.com>
    Signed-off-by: Denys Vlasenko <dvlasenk@redhat.com>
Comment 3 Jakub Filak 2013-07-02 06:51:11 EDT
Updates to this package have been released [1]. If you have time to update the package and re-test, please do so and report the results here.

1: http://koji.fedoraproject.org/koji/buildinfo?buildID=430794

Note You need to log in before you can comment on or make changes to this bug.