This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 98031 - Mozilla crash
Mozilla crash
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: mozilla (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-06-25 13:07 EDT by Tim Waugh
Modified: 2007-04-18 12:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-22 22:36:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2003-06-25 13:07:50 EDT
Description of problem:
Mozilla crashes when viewing the attachment to bug #97865.

Version-Release number of selected component (if applicable):
mozilla-1.4-10

How reproducible:
100%

Steps to Reproduce:
1. https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=92612&action=view
Comment 1 Peter van Egdom 2003-06-26 07:13:27 EDT
The same problem occurs when downloading the GeeXboX iso image at :

http://geexbox.free.fr/us/pages/down.html
Comment 2 Christopher Blizzard 2003-07-03 14:43:40 EDT
Wow, interesting.
Comment 3 Christopher Blizzard 2003-08-25 15:29:16 EDT
Hmm, I'm not seeing a crash now.  Can you try this with an up to date cambridge
tree?  (Updated X, fontconfig, freetype?)
Comment 4 Peter van Egdom 2003-08-26 18:17:04 EDT
I also can't reproduce this problem anymore with Red Hat Enterprise Linux
release 2.9.5AS (Taroon).

Using the following components :

 XFree86-4.3.0-16
 mozilla-1.4-3.0.11
 freetype-2.1.4-4.0
 fontconfig-2.1-9
Comment 5 Tim Waugh 2003-08-28 13:04:49 EDT
Still happening for me:

XFree86-4.3.0-22.1
fontconfig-2.2.1-4
freetype-2.1.4-4.1

Although if I try as a different user on the same machine it is fine. :-/
Comment 6 Christopher Blizzard 2003-09-03 11:05:51 EDT
Do you have any fonts installed in your path that you can't read?  Any .fon font
files in your private ~/.fonts dir?
Comment 7 Tim Waugh 2003-09-03 12:43:25 EDT
It still happens after I do this:

xset fp=
/usr/X11R6/lib/X11/fonts/misc/,/usr/X11R6/lib/X11/fonts/Speedo/,/usr/X11R6/lib/X11/fonts/Type1/,/usr/X11R6/lib/X11/fonts/75dpi/,/usr/X11R6/lib/X11/fonts/100dpi/

and after I have done 'mv .fonts .fonts-orig'.  Is that sufficient to rule out
fonts, or do I need to do something else?
Comment 8 Christopher Blizzard 2003-09-03 13:44:30 EDT
how about:

NSPR_LOG_MODULES=XftFontLoad:5 mozilla

the mozilla script actually eats stdout, so you might have to set up the
environment vars and run mozilla-bin directly.  But that should tell you what
fonts are being loaded.

Is it an X error or a crash?  If it's a crash, can you get me a stack trace?
Comment 9 Tim Waugh 2003-09-04 08:28:20 EDT
Got the output and also a stack trace:

[0x8307c68] setting up pattern with the following specification:
        lang group: x-western
        adding generic family: serif
        point,pixel size: 12,240
        slant: roman
        weight: (orig,calc) 400,100
matched the following (21) fonts:
        Nimbus Roman No9 L
        Nimbus Roman No9 L
        Luxi Serif
        Lansbury
        console8x16
        Luxi Mono
        Symphony in ABC
        AmericanIndian
        Violation
        Honest John's Shadow
        Courier
        Edwardian Script ITC
        Fixed
        MiscFixed
        MiscFixed
        MiscFixed
        MiscFixed
        Kochi Mincho
        Commodore 64
        SF Fedora Titles
        Standard Symbols L
[0x8694200] setting up pattern with the following specification:
        adding non-generic families: sans,
        lang group: x-western
        adding generic family: serif
        point,pixel size: 10,200
        slant: roman
        weight: (orig,calc) 400,100
matched the following (24) fonts:
        Luxi Sans
        Luxi Sans
        Nimbus Sans L
        Nimbus Roman No9 L
        Nimbus Roman No9 L
        Lansbury
        Luxi Mono
        Symphony in ABC
        AmericanIndian
        Violation
        Honest John's Shadow
        Courier
        Edwardian Script ITC
        MiscFixed
        Fixed
        MiscFixed
        console8x16
        MiscFixed
        MiscFixed
        Kochi Gothic
        Kochi Mincho
        Commodore 64
        SF Fedora Titles
        Standard Symbols L
[0x86b6578] setting up pattern with the following specification:
        adding non-generic families: sans,
        lang group: x-western
        adding generic family: serif
        point,pixel size: 10,200
        slant: roman
        weight: (orig,calc) 700,200
matched the following (24) fonts:
        Luxi Sans
        Luxi Sans
        Nimbus Sans L
        Nimbus Sans L
        Nimbus Roman No9 L
        Nimbus Roman No9 L
        Luxi Mono
        Kinkie
        Courier
        Lansbury
        AmericanIndian
        MiscFixed
        MiscFixed
        MiscFixed
        Fixed
        MiscFixed
        console8x16
        MiscFixed
        MiscFixed
        Kochi Gothic
        Kochi Mincho
        Commodore 64
        SF Fedora Titles
        Standard Symbols L
[0x86b8580] setting up pattern with the following specification:
        adding non-generic families: sans,
        lang group: x-western
        adding generic family: serif
        point,pixel size: 8,155
        slant: roman
        weight: (orig,calc) 400,100
matched the following (29) fonts:
        Luxi Sans
        Luxi Sans
        Nimbus Sans L
        Nimbus Roman No9 L
        Nimbus Roman No9 L
        Lansbury
        Luxi Mono
        Symphony in ABC
        AmericanIndian
        Violation
        Honest John's Shadow
        Courier
        Edwardian Script ITC
        LucidaTypewriter
        MiscFixed
        MiscFixed
        MiscFixed
        MiscFixed
        console8x8
        Fixed
        MiscFixed
        console8x16
        MiscFixed
        MiscFixed
        Kochi Gothic
        Kochi Mincho
        Commodore 64
        SF Fedora Titles
        Standard Symbols L
[0x85dbc18] setting up pattern with the following specification:
        lang group: x-western
        adding generic family: serif
        point,pixel size: 12,240
        slant: roman
        weight: (orig,calc) 400,100
matched the following (21) fonts:
        Nimbus Roman No9 L
        Nimbus Roman No9 L
        Luxi Serif
        Lansbury
        console8x16
        Luxi Mono
        Symphony in ABC
        AmericanIndian
        Violation
        Honest John's Shadow
        Courier
        Edwardian Script ITC
        Fixed
        MiscFixed
        MiscFixed
        MiscFixed
        MiscFixed
        Kochi Mincho
        Commodore 64
        SF Fedora Titles
        Standard Symbols L
[0x87d5408] setting up pattern with the following specification:
        lang group: x-western
        adding generic family: monospace
        point,pixel size: 9,180
        slant: roman
        weight: (orig,calc) 400,100
matched the following (21) fonts:
        Luxi Mono
        Luxi Mono
        Nimbus Mono L
        Lansbury
        LucidaTypewriter
        MiscFixed
        AmericanIndian
        Violation
        Courier
        Edwardian Script ITC
        MiscFixed
        Fixed
        MiscFixed
        console8x16
        MiscFixed
        MiscFixed
        Kochi Gothic
        Commodore 64
        SF Fedora Titles
        Kochi Mincho
        Standard Symbols L
[0x8506fe8] setting up pattern with the following specification:
        lang group: x-western
        adding generic family: serif
        point,pixel size: 12,240
        slant: roman
        weight: (orig,calc) 400,100
matched the following (21) fonts:
        Nimbus Roman No9 L
        Nimbus Roman No9 L
        Luxi Serif
        Lansbury
        console8x16
        Luxi Mono
        Symphony in ABC
        AmericanIndian
        Violation
        Honest John's Shadow
        Courier
        Edwardian Script ITC
        Fixed
        MiscFixed
        MiscFixed
        MiscFixed
        MiscFixed
        Kochi Mincho
        Commodore 64
        SF Fedora Titles
        Standard Symbols L
[0x86c0508] setting up pattern with the following specification:
        lang group: x-western
        adding generic family: monospace
        point,pixel size: 9,180
        slant: roman
        weight: (orig,calc) 400,100
matched the following (21) fonts:
        Luxi Mono
        Luxi Mono
        Nimbus Mono L
        Lansbury
        LucidaTypewriter
        MiscFixed
        AmericanIndian
        Violation
        Courier
        Edwardian Script ITC
        MiscFixed
        Fixed
        MiscFixed
        console8x16
        MiscFixed
        MiscFixed
        Kochi Gothic
        Commodore 64
        SF Fedora Titles
        Kochi Mincho
        Standard Symbols L

#0  0x407e4376 in XftDrawGlyphFontSpec () from /usr/X11R6/lib/libXft.so.2
#1  0x4249242f in nsFontMetricsXft::DrawString(char const*, unsigned, int, int,
int const*, nsRenderingContextGTK*, nsDrawingSurfaceGTK*) ()
   from /usr/lib/mozilla-1.4/components/libgfx_gtk.so
#2  0x4247dbe7 in nsRenderingContextGTK::DrawString(char const*, unsigned, int,
int, int const*) () from /usr/lib/mozilla-1.4/components/libgfx_gtk.so
#3  0x40da4c0b in NSGetModule ()
   from /usr/lib/mozilla-1.4/components/libgklayout.so
#4  0x40da14e5 in NSGetModule ()
   from /usr/lib/mozilla-1.4/components/libgklayout.so
#5  0x40d58dde in NSGetModule ()
   from /usr/lib/mozilla-1.4/components/libgklayout.so
#6  0x40d51b94 in NSGetModule ()
   from /usr/lib/mozilla-1.4/components/libgklayout.so
#7  0x40d6abe6 in NSGetModule ()
   from /usr/lib/mozilla-1.4/components/libgklayout.so
#8  0x40d519aa in NSGetModule ()
   from /usr/lib/mozilla-1.4/components/libgklayout.so
#9  0x40d58dde in NSGetModule ()
   from /usr/lib/mozilla-1.4/components/libgklayout.so
#10 0x40d51b94 in NSGetModule ()
   from /usr/lib/mozilla-1.4/components/libgklayout.so
#11 0x40d6abe6 in NSGetModule ()
---Type <return> to continue, or q <return> to quit---
   from /usr/lib/mozilla-1.4/components/libgklayout.so
#12 0x40d519aa in NSGetModule ()
   from /usr/lib/mozilla-1.4/components/libgklayout.so
#13 0x40d58dde in NSGetModule ()
   from /usr/lib/mozilla-1.4/components/libgklayout.so
#14 0x40d51b94 in NSGetModule ()
   from /usr/lib/mozilla-1.4/components/libgklayout.so
#15 0x40d6abe6 in NSGetModule ()
   from /usr/lib/mozilla-1.4/components/libgklayout.so
#16 0x40d519aa in NSGetModule ()
   from /usr/lib/mozilla-1.4/components/libgklayout.so
#17 0x40d58dde in NSGetModule ()
   from /usr/lib/mozilla-1.4/components/libgklayout.so
#18 0x40d58cd6 in NSGetModule ()
   from /usr/lib/mozilla-1.4/components/libgklayout.so
#19 0x40d6ab56 in NSGetModule ()
   from /usr/lib/mozilla-1.4/components/libgklayout.so
#20 0x40d6be09 in NSGetModule ()
   from /usr/lib/mozilla-1.4/components/libgklayout.so
#21 0x40d9914a in NSGetModule ()
   from /usr/lib/mozilla-1.4/components/libgklayout.so
#22 0x41061fc1 in NSGetModule ()
   from /usr/lib/mozilla-1.4/components/libgklayout.so
---Type <return> to continue, or q <return> to quit---
#23 0x41067855 in NSGetModule ()
   from /usr/lib/mozilla-1.4/components/libgklayout.so
#24 0x4106769e in NSGetModule ()
   from /usr/lib/mozilla-1.4/components/libgklayout.so
#25 0x4106601f in NSGetModule ()
   from /usr/lib/mozilla-1.4/components/libgklayout.so
#26 0x41068bd7 in NSGetModule ()
   from /usr/lib/mozilla-1.4/components/libgklayout.so
#27 0x410617dc in NSGetModule ()
   from /usr/lib/mozilla-1.4/components/libgklayout.so


#28 0x4223493a in nsCommonWidget::DispatchEvent(nsGUIEvent*, nsEventStatus&) ()
   from /usr/lib/mozilla-1.4/components/libwidget_gtk2.so
#29 0x4222cced in nsWindow::OnExposeEvent(_GtkWidget*, _GdkEventExpose*) ()
   from /usr/lib/mozilla-1.4/components/libwidget_gtk2.so
#30 0x42230e19 in nsWindow::HideWindowChrome(int) ()
   from /usr/lib/mozilla-1.4/components/libwidget_gtk2.so
#31 0x401b98c2 in _gtk_marshal_BOOLEAN__BOXED ()
   from /usr/lib/libgtk-x11-2.0.so.0
#32 0x40434cb0 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#33 0x40446bbf in g_signal_emit_by_name () from /usr/lib/libgobject-2.0.so.0
#34 0x40445a0d in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
Comment 10 Christopher Blizzard 2003-09-23 14:39:48 EDT
Reporter, can you try this again with the most recent XFree and
xrender/xft/freetype packages?  I suspect this is fixed now.
Comment 11 Christopher Blizzard 2003-10-08 13:25:30 EDT
Tim, your attachment and comments were lost during the bugzilla lossage.
Comment 12 Tim Waugh 2003-10-08 14:44:41 EDT
"It still isn't fixed," I think I said.

mozilla-1.4.1-4
XFree86-4.3.0-37
freetype-2.1.4-5
Comment 13 Christopher Blizzard 2003-10-09 14:13:18 EDT
Still can't reproduce.
Comment 14 Christopher Blizzard 2003-10-22 13:55:53 EDT
Hot damn, I think I have a patch for this.
Comment 15 Christopher Blizzard 2003-10-22 14:04:49 EDT
Upstream bug, for the record:

http://bugzilla.mozilla.org/show_bug.cgi?id=213734
Comment 16 Christopher Blizzard 2003-10-22 16:19:45 EDT
Can you try the 1.4.1-11 build in dist-10-scratch?  It fixes the crash here for me.
Comment 17 Christopher Blizzard 2003-10-22 22:36:42 EDT
I've moved this into dist-10.  Marking fixed.
Comment 18 Tim Waugh 2003-10-27 07:52:10 EST
Yes, this is fixed now.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.