Bug 980451 - When configure NFSv4 domain, it will report an error
When configure NFSv4 domain, it will report an error
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Ryan Barry
Virtualization Bugs
:
: 1022236 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-02 08:05 EDT by wanghui
Modified: 2014-01-21 14:43 EST (History)
14 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-5.el6
Doc Type: Bug Fix
Doc Text:
Previously when configuring the NFSv4 domain (for example domain1), it would report an error "No such file or directory" The code has been modified and this no longer happens.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 14:43:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 18278 None None None Never

  None (edit)
Description wanghui 2013-07-02 08:05:50 EDT
Description of problem:
When configure the NFSv4 domain, it will report an error.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.5-20130222.0.auto1707.el6.iso
ovirt-node-3.0.0-1.999.20130701111251git99aadc6.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install rhevh6.5.
2. Configure the NFSv4 domain with domain1.

Actual results:
After step2, it will report an error.

Expected results:
After step2, it can configure NFSv4 domain successfully.

Additional info:
There is also an error info when delete the NFSv4 domain.
There is also an error info when your change the NFSv4 domain name with other name.
Comment 2 RHEL Product and Program Management 2013-10-13 23:14:54 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 Fabian Deutsch 2013-10-22 15:46:40 EDT
*** Bug 1022236 has been marked as a duplicate of this bug. ***
Comment 6 wanghui 2013-10-28 04:10:01 EDT
Test version:
rhevh-6.5-20131024.1.0.iso
ovirt-node-3.0.1-6.el6.noarch

Test steps:
1. Install rhevh-6.5-20131024.1.0.iso.
2. Configure the NFSv4 domain with domain1.
3. Check in /etc/idmapd.conf
4. Change the NFSv4 domain name in TUI.
5. Delete NFSv4 domain name in TUI.

Test result:
1. After step2, it can configure NFSv4 domain successfully.
2. After step3, it can persist NFSv4 domain in /etc/idmapd.conf succuessfully.
3. After step4, it can change the NFSv4 domain name successfully in TUI.
4. After step5, it can delete NFSv4 domain name in TUI successfully.

This bug is fixed in rhevh-6.5-20131024.1.0.iso. So change the status from ON_QA to VERIFIED.
Comment 8 Cheryn Tan 2013-11-07 19:27:11 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 10 errata-xmlrpc 2014-01-21 14:43:00 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.