Bug 980504 - Doc does not mention starting the openvswitch services
Doc does not mention starting the openvswitch services
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: doc-Installation_and_Configuration_Guide (Show other bugs)
3.0
Unspecified Unspecified
medium Severity medium
: async
: 3.0
Assigned To: Stephen Gordon
ecs-bugs
: Documentation, Triaged, ZStream
Depends On:
Blocks: 1011085
  Show dependency treegraph
 
Reported: 2013-07-02 10:24 EDT by Attila Darazs
Modified: 2014-01-05 23:25 EST (History)
4 users (show)

See Also:
Fixed In Version: Red_Hat_OpenStack-Installation_and_Configuration_Guide-3-web-en-US-3-31.el6eng
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Build: CSProcessor Builder Version 1.10 Build Name: 15807, Installation and Configuration Guide-3-1 Build Date: 01-07-2013 17:33:39 Topic ID: 16774-458430 [Latest]
Last Closed: 2014-01-05 23:25:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Attila Darazs 2013-07-02 10:24:51 EDT
Title: Configuring the L3 Agent

Describe the issue:
"Use the ovs-ctl command to create the external bridge named br-ex.

# ovs-vsctl add-br br-ex"

First, the command's name is ovs-vsctl, second, the documentation doesn't mention before at any point that the "openvswitch" service should be started and enabled before using this command, otherwise the command fails.

Suggestions for improvement:
Add somewhere these commands before that step:
# service openvswitch start
# chkconfig openvswitch on
Comment 2 Attila Darazs 2013-07-02 11:27:06 EDT
I see it is written right on the next page. Not sure how to solve this. Maybe switch around the two chapters?
Comment 3 Stephen Gordon 2013-07-02 11:51:16 EDT
(In reply to Attila Darazs from comment #2)
> I see it is written right on the next page. Not sure how to solve this.
> Maybe switch around the two chapters?

Yeah there is a bit of a chicken/egg issue here. I suspect they will have to be broken up a bit further because I'm not sure that you can easily complete the plugin agent setup procedure as written if you haven't completed the L3 one (and vice versa).
Comment 4 Attila Darazs 2013-07-02 13:14:40 EDT
The L3 config parts might be needed for the other parts, but the basic openvswitch service can be started earlier, it worked for me like that.
Comment 5 Bob Kukura 2013-07-24 14:42:18 EDT
The L2 agent should definitely be configured and started prior to the DHCP and L3 agents. Layer 3 sits on top of Layer 2, and cannot function without it.
Comment 6 Stephen Gordon 2013-08-06 11:45:20 EDT
Content Specification ID: 15807
Revision: 492883

Moved the L2 agent configuration sections ahead of the L3 agent one.

Note You need to log in before you can comment on or make changes to this bug.