Bug 980640 - subscription-manager-gui My Installed Products > Status is incomplete for multiple attachments
subscription-manager-gui My Installed Products > Status is incomplete for mul...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.10
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Carter Kozak
IDM QE LIST
:
Depends On:
Blocks: rhsm-rhel510
  Show dependency treegraph
 
Reported: 2013-07-02 18:13 EDT by John Sefler
Modified: 2014-09-14 20:08 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 19:12:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Status of an installed product covered by multiple contracts appears broken (80.30 KB, image/png)
2013-07-02 18:13 EDT, John Sefler
no flags Details
Installed product status on GUI (151.06 KB, image/png)
2013-07-15 08:28 EDT, Shwetha Kallesh
no flags Details
Installed product status on GUI for multiple subscriptions (142.62 KB, image/png)
2013-07-15 08:34 EDT, Shwetha Kallesh
no flags Details

  None (edit)
Description John Sefler 2013-07-02 18:13:19 EDT
Created attachment 767985 [details]
Status of an installed product covered by multiple contracts appears broken

Description of problem:
See screenshot


Version-Release number of selected component (if applicable):
[root@jsefler-5 ~]# rpm -q subscription-manager-gui
subscription-manager-gui-1.8.11-1.el5


How reproducible:


Steps to Reproduce:
Register an 8 socket system to candlepin with TESTDATA deployed and attach the following subscriptions....

[root@jsefler-5 ~]# subscription-manager facts | grep socket
cpu.core(s)_per_socket: 1
cpu.cpu_socket(s): 8
dmi.processor.socket_designation: CPU 1
[root@jsefler-5 ~]# subscription-manager list --consumed
+-------------------------------------------+
   Consumed Subscriptions
+-------------------------------------------+
Subscription Name: Awesome OS for All Arch (just x86_64 content)
Provides:          Awesome OS for All Arch (just x86_64 content) Bits
SKU:               awesomeos-all-just-86_64-cont
Contract:          102
Account:           12331131231
Serial:            7521752372803824767
Pool ID:           8a90f8203f9b0052013f9b01d0c70616
Active:            True
Quantity Used:     5
Service Level:     None
Service Type:      None
Status Details:    
Starts:            06/30/2013
Ends:              06/30/2014

Subscription Name: Awesome OS for x86_64
Provides:          Awesome OS for x86_64 Bits
SKU:               awesomeos-x86_64
Contract:          78
Account:           12331131231
Serial:            8753634718456046221
Pool ID:           8a90f8203f9b0052013f9b01cf9c0592
Active:            True
Quantity Used:     3
Service Level:     None
Service Type:      None
Status Details:    
Starts:            06/30/2013
Ends:              06/30/2014



Actual results:
Then see attached screenshot.
Status: Covered by contract 78 through

Expected results:
Status Covered by contracts 78,102 through 06/30/2014
Comment 1 RHEL Product and Program Management 2013-07-02 18:17:13 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Carter Kozak 2013-07-09 16:46:55 EDT
This fix required a small logic change in both subscription-manager and candlepin

subscription-manager:
commit 2e1c84a30be11b85138c92d44a28a44d9e010354
Author: ckozak <ckozak@redhat.com>
Date:   Mon Jul 8 12:02:32 2013 -0400

    980640: include stacked ents in provided

candlepin:
commit 70f58abb057f2e414efc7afaa055f075644e5d52
Author: ckozak <ckozak@redhat.com>
Date:   Mon Jul 8 12:58:00 2013 -0400

    980640: fix stacked ent providing logic
Comment 5 Shwetha Kallesh 2013-07-15 08:28:34 EDT
Created attachment 773708 [details]
Installed product status on GUI

[root@localhost ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.8.17-1
subscription-manager: 1.8.13-1.el5
python-rhsm: 1.8.13-1.git.0.85d7af5.el5



[root@localhost ~]# subscription-manager facts --list 
cpu.core(s)_per_socket: 1
cpu.cpu_socket(s): 8

[root@localhost ~]# subscription-manager list --consumed
+-------------------------------------------+
   Consumed Subscriptions
+-------------------------------------------+
Subscription Name: Awesome OS Instance Based (Standard Support)
Provides:          Awesome OS Instance Server Bits
SKU:               awesomeos-instancebased
Contract:          43
Account:           12331131231
Serial:            2871763104569787014
Pool ID:           8ac6a3a23fe1b9aa013fe1bab94d07f9
Active:            True
Quantity Used:     1
Service Level:     Standard
Service Type:      L1-L3
Status Details:    
Starts:            07/15/2013
Ends:              07/15/2014
Comment 6 Shwetha Kallesh 2013-07-15 08:34:39 EDT
Created attachment 773709 [details]
Installed product status on GUI for multiple subscriptions

[root@localhost ~]# subscription-manager list --consumed
+-------------------------------------------+
   Consumed Subscriptions
+-------------------------------------------+
Subscription Name: Awesome OS Instance Based (Standard Support)
Provides:          Awesome OS Instance Server Bits
SKU:               awesomeos-instancebased
Contract:          43
Account:           12331131231
Serial:            2871763104569787014
Pool ID:           8ac6a3a23fe1b9aa013fe1bab94d07f9
Active:            True
Quantity Used:     1
Service Level:     Standard
Service Type:      L1-L3
Status Details:    
Starts:            07/15/2013
Ends:              07/15/2014

Subscription Name: Awesome OS Instance Based (Standard Support)
Provides:          Awesome OS Instance Server Bits
SKU:               awesomeos-instancebased
Contract:          42
Account:           12331131231
Serial:            1054656422365373147
Pool ID:           8ac6a3a23fe1b9aa013fe1bab9650808
Active:            True
Quantity Used:     1
Service Level:     Standard
Service Type:      L1-L3
Status Details:    
Starts:            07/15/2013
Ends:              07/15/2014
Comment 8 errata-xmlrpc 2013-09-30 19:12:17 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1332.html

Note You need to log in before you can comment on or make changes to this bug.