Bug 980695 - Diff is highlighting changes in wrong order
Diff is highlighting changes in wrong order
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: Web-UI (Show other bugs)
1.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Casperson
Lucas Costi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 00:09 EDT by Lucas Costi
Modified: 2014-08-04 18:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-08 20:00:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lucas Costi 2013-07-03 00:09:58 EDT
Description of problem:

The diff tool systems to be doing the change highlighting in the wrong order.

The order of the revisions displayed on-screen for left/right is correct (i.e. the newer revision is on the left), but the change highlighting seems to show the revision on the left as being the superseded one.

i.e. something added to the newer revision (displayed on the left), is shown in red with a strikethrough, and something that was replaced in the older revision (displayed on the right), is shown with a bluey background.

The highlighting probably should be the other way around?

Bug is  present in the Next-UI Build 201307011553
Comment 1 Lucas Costi 2013-07-03 00:17:22 EDT
arrg, the first sentence in the description was supposed to be:
"The diff tool seems to be doing the change highlighting in the wrong order."
Comment 2 Matthew Casperson 2013-07-09 02:16:50 EDT
Fixed in 201307091606

Diff order is reversed, so the colours make more sense.

NOTE:
When QAing bug fixes, please make sure the build you are using is equal to or higher than the build identified above. Be aware that this fix may have only been applied in PressGang Next at this time, or it may not be currently applied in any production system, in which case it can only be verified at a later date.
Comment 4 Lucas Costi 2013-07-29 19:00:45 EDT
Verified that it is working now, although the sides of the displayed revisions have now changed (i.e. the older revision is now on the left, and the newer revision is now on the right).

As this it looks like this is the intended usage of mergely, It might be worth mentioning this change in the release notes.
Comment 5 Lee Newson 2013-08-02 01:45:14 EDT
Thanks Lucas.

I believe what we probably should do is look at adding headers to the diff view so that it will display the revision number, as that would make things a lot clearer. As such I've created BZ#991295 to deal with that.

Note You need to log in before you can comment on or make changes to this bug.