Bug 980796 - 3.2.2.1.3 Unnecessary steps in instruction to produce USB stick with dd
3.2.2.1.3 Unnecessary steps in instruction to produce USB stick with dd
Status: CLOSED CURRENTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: install-guide (Show other bugs)
devel
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Bokoc
Fedora Docs QA
:
: 981972 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 05:08 EDT by Mikhail Gusarov
Modified: 2013-07-25 11:33 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-25 11:15:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikhail Gusarov 2013-07-03 05:08:33 EDT
Description of problem:

Steps 3 (checking partition layout on USB stick) and 4 (checking fs
on a partition on USB stick) are unnecessary: step 5 overwrites whole
USB device and hence previous partition layout and filesystems do not matter
anymore.

Version-Release number of selected component (if applicable):

Docs for Fedora 19

How reproducible: always

Steps to Reproduce:
1. Follow the steps 1, 2 and 5 of instruction
2. Boot the resulting USB device

Actual results:

USB device boots properly

Expected results:

Something should go wrong, as steps in guide were skipped

Additional info:
Comment 1 Petr Bokoc 2013-07-08 03:48:16 EDT
*** Bug 981972 has been marked as a duplicate of this bug. ***
Comment 2 Petr Bokoc 2013-07-09 14:48:42 EDT
Hello Mikhail,

thank you for reporting this issue. You're indeed right, steps 3 and 4 are unnecessary. The procedure in question has been changed accordingly in commit d881d1643a90911f0ff2ed04fbc71fe1b76c5331.
Comment 3 David Tonhofer 2013-07-09 18:08:18 EDT
Additional note: 

The example given uses a DVD iso image (judging by the label) and I have never once been able to get a bootable stick from a DVD iso image using "dd" alone (dd works perfectly well for CD iso images). 

Can anyone confirm this?
Comment 5 Petr Bokoc 2013-07-25 11:33:12 EDT
It's going to be visible online in an hour.

Note You need to log in before you can comment on or make changes to this bug.