Bug 981972 - Unnecessary steps in "creating livecd USB using dd"
Unnecessary steps in "creating livecd USB using dd"
Status: CLOSED DUPLICATE of bug 980796
Product: Fedora Documentation
Classification: Fedora
Component: install-guide (Show other bugs)
devel
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Bokoc
Fedora Docs QA
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-07 07:56 EDT by David Tonhofer
Modified: 2013-07-08 03:48 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-08 03:48:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Tonhofer 2013-07-07 07:56:15 EDT
Description of problem:

At

http://docs.fedoraproject.org/en-US/Fedora/19/html/Installation_Guide/Making_USB_Media-UNIX_Linux.html#Making_USB_Media-UNIX_Linux-RHEL_Fedora-dd

we read:

"Your flash drive must have a single partition with a vfat file system. To determine how it is formatted..."

However, it is completely unnecessary to do so, as the whole partition table of the flash drive is overwritten in the next line:

dd if=path/image_name.iso of=device

One could instead indicate how the flash drive partition table changes. E.g.

Starting with a brand-new 16GiB flahs drive, fdisk says:

-------------
Disk /dev/sdc: 15.5 GB, 15500673024 bytes
40 heads, 40 sectors/track, 18921 cylinders, total 30274752 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xc3072e18

   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1            8064    30274751    15133344    c  W95 FAT32 (LBA)
-------------

Then we apply "dd", and afterwards, fdisk says:

-------------
WARNING: GPT (GUID Partition Table) detected on '/dev/sdc'! The util fdisk doesn't support GPT. Use GNU Parted.


Command (m for help): p

Disk /dev/sdc: 15.5 GB, 15500673024 bytes
255 heads, 63 sectors/track, 1884 cylinders, total 30274752 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x3f5719e1

   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1   *           0     1798143      899072    0  Empty
/dev/sdc2             172       10199        5014   ef  EFI (FAT-12/16/32)
/dev/sdc3           10248       50407       20080    0  Empty
------------

Will booting off the flash drive it actually work? Will try now.

Additionally, the example command uses a DVD iso:

------------
# dd if=~/Download/Fedora-19-x86_64-DVD.iso of=/dev/sdc
------------

I have to admit that the trick with "dd" never worked for DVD ISOs for me, though it always worked for CD ISOs. Not sure it's my motherboards...
Comment 1 Petr Bokoc 2013-07-08 03:48:16 EDT
Hello David,

thank you for reporting this. However, the same issue has already been reported a bit earlier - see bug 980796.

I'll fix the procedure right away.

*** This bug has been marked as a duplicate of bug 980796 ***

Note You need to log in before you can comment on or make changes to this bug.