Bug 980805 - [RHEL 5] tzdata updates needed for changes in Morocco's DST 2013
[RHEL 5] tzdata updates needed for changes in Morocco's DST 2013
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: tzdata (Show other bugs)
5.9
All Linux
urgent Severity high
: rc
: ---
Assigned To: Petr Machata
qe-baseos-daemons
: ZStream
: 982277 (view as bug list)
Depends On:
Blocks: 982277
  Show dependency treegraph
 
Reported: 2013-07-03 05:36 EDT by Nilesh Parmar
Modified: 2015-05-04 21:38 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-09 02:51:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nilesh Parmar 2013-07-03 05:36:55 EDT
Morocco is going to observe DST time change on 7th July, more details in below links:

http://www.timeanddate.com/news/time/morocco-dst-ramadan-2013.html

http://www.timeanddate.com/worldclock/clockchange.html?n=60

latest version of tzdata on RHEL 5: tzdata-2013c-1.el5

Changelog shows:

* Wed Mar 13 2013 Petr Machata <pmachata@redhat.com> - 2013b-1
- Upstream 2013b
  - Paraguay will end DST on March 24 this year
  - Haiti uses US daylight-saving rules this year
  - Morocco does not observe DST during Ramadan    <---

Steps to reproduce:

[root@localhost ~]# zdump -v /usr/share/zoneinfo/Africa/Casablanca | grep 2013 | grep isdst

Actual result:

/usr/share/zoneinfo/Africa/Casablanca  Sun Apr 28 01:59:59 2013 UTC = Sun Apr 28 01:59:59 2013 WET isdst=0 gmtoff=0
/usr/share/zoneinfo/Africa/Casablanca  Sun Apr 28 02:00:00 2013 UTC = Sun Apr 28 03:00:00 2013 WEST isdst=1 gmtoff=3600
/usr/share/zoneinfo/Africa/Casablanca  Tue Jul  9 01:59:59 2013 UTC = Tue Jul  9 02:59:59 2013 WEST isdst=1 gmtoff=3600
/usr/share/zoneinfo/Africa/Casablanca  Tue Jul  9 02:00:00 2013 UTC = Tue Jul  9 02:00:00 2013 WET isdst=0 gmtoff=0
/usr/share/zoneinfo/Africa/Casablanca  Thu Aug  8 01:59:59 2013 UTC = Thu Aug  8 01:59:59 2013 WET isdst=0 gmtoff=0
/usr/share/zoneinfo/Africa/Casablanca  Thu Aug  8 02:00:00 2013 UTC = Thu Aug  8 03:00:00 2013 WEST isdst=1 gmtoff=3600
/usr/share/zoneinfo/Africa/Casablanca  Sun Sep 29 01:59:59 2013 UTC = Sun Sep 29 02:59:59 2013 WEST isdst=1 gmtoff=3600
/usr/share/zoneinfo/Africa/Casablanca  Sun Sep 29 02:00:00 2013 UTC = Sun Sep 29 02:00:00 2013 WET isdst=0 gmtoff=0


Expected result: 

Changes should take place on July 7th and August 10th, respectively.
Comment 5 Jan Kurik 2013-07-08 11:08:56 EDT
*** Bug 982277 has been marked as a duplicate of this bug. ***
Comment 7 errata-xmlrpc 2013-07-09 02:51:38 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1025.html

Note You need to log in before you can comment on or make changes to this bug.