Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 980807 - [RHEL 6] tzdata updates needed for changes in Morocco's DST 2013
Summary: [RHEL 6] tzdata updates needed for changes in Morocco's DST 2013
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tzdata
Version: 6.4
Hardware: All
OS: Linux
urgent
high
Target Milestone: rc
: ---
Assignee: Petr Machata
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
: 982278 (view as bug list)
Depends On:
Blocks: 981019 981020 982278
TreeView+ depends on / blocked
 
Reported: 2013-07-03 09:42 UTC by Nilesh Parmar
Modified: 2018-12-03 19:15 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 981019 981020 (view as bug list)
Environment:
Last Closed: 2013-07-09 06:51:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2013:1025 0 normal SHIPPED_LIVE tzdata enhancement update 2013-07-09 10:50:24 UTC

Description Nilesh Parmar 2013-07-03 09:42:34 UTC
Morocco is going to observe DST time change on 7th July, more details in below links:

http://www.timeanddate.com/news/time/morocco-dst-ramadan-2013.html

http://www.timeanddate.com/worldclock/clockchange.html?n=60

latest version of tzdata on RHEL 6: tzdata-2013c-1.el6

Changelog shows:

* Wed Mar 13 2013 Petr Machata <pmachata@redhat.com> - 2013b-1
- Upstream 2013b
  - Paraguay will end DST on March 24 this year
  - Haiti uses US daylight-saving rules this year
  - Morocco does not observe DST during Ramadan       <---


Steps to reproduce:

[root@localhost ~]# zdump -v /usr/share/zoneinfo/Africa/Casablanca | grep 2013 | grep isdst

Actual result:

/usr/share/zoneinfo/Africa/Casablanca  Sun Apr 28 01:59:59 2013 UTC = Sun Apr 28 01:59:59 2013 WET isdst=0 gmtoff=0
/usr/share/zoneinfo/Africa/Casablanca  Sun Apr 28 02:00:00 2013 UTC = Sun Apr 28 03:00:00 2013 WEST isdst=1 gmtoff=3600
/usr/share/zoneinfo/Africa/Casablanca  Tue Jul  9 01:59:59 2013 UTC = Tue Jul  9 02:59:59 2013 WEST isdst=1 gmtoff=3600
/usr/share/zoneinfo/Africa/Casablanca  Tue Jul  9 02:00:00 2013 UTC = Tue Jul  9 02:00:00 2013 WET isdst=0 gmtoff=0
/usr/share/zoneinfo/Africa/Casablanca  Thu Aug  8 01:59:59 2013 UTC = Thu Aug  8 01:59:59 2013 WET isdst=0 gmtoff=0
/usr/share/zoneinfo/Africa/Casablanca  Thu Aug  8 02:00:00 2013 UTC = Thu Aug  8 03:00:00 2013 WEST isdst=1 gmtoff=3600
/usr/share/zoneinfo/Africa/Casablanca  Sun Sep 29 01:59:59 2013 UTC = Sun Sep 29 02:59:59 2013 WEST isdst=1 gmtoff=3600
/usr/share/zoneinfo/Africa/Casablanca  Sun Sep 29 02:00:00 2013 UTC = Sun Sep 29 02:00:00 2013 WET isdst=0 gmtoff=0

Expected result: 

Changes should take place on July 7th and August 10th, respectively.

Comment 8 Jan Kurik 2013-07-08 15:10:00 UTC
*** Bug 982278 has been marked as a duplicate of this bug. ***

Comment 10 errata-xmlrpc 2013-07-09 06:51:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1025.html


Note You need to log in before you can comment on or make changes to this bug.