Bug 980949 - ifuse needs to be patched for libimobiledevice 1.1.5 new ABI
Summary: ifuse needs to be patched for libimobiledevice 1.1.5 new ABI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ifuse
Version: 19
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:b2a640d9220dd01c749b3e7c8bc...
: 1009337 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-03 15:54 UTC by Mick Ohrberg
Modified: 2013-10-18 19:45 UTC (History)
7 users (show)

Fixed In Version: ifuse-1.1.2-7.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-10-13 19:52:04 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (11.34 KB, text/plain)
2013-07-03 15:54 UTC, Mick Ohrberg
no flags Details
File: cgroup (140 bytes, text/plain)
2013-07-03 15:54 UTC, Mick Ohrberg
no flags Details
File: core_backtrace (980 bytes, text/plain)
2013-07-03 15:55 UTC, Mick Ohrberg
no flags Details
File: dso_list (2.09 KB, text/plain)
2013-07-03 15:55 UTC, Mick Ohrberg
no flags Details
File: environ (2.11 KB, text/plain)
2013-07-03 15:55 UTC, Mick Ohrberg
no flags Details
File: limits (1.29 KB, text/plain)
2013-07-03 15:55 UTC, Mick Ohrberg
no flags Details
File: maps (10.91 KB, text/plain)
2013-07-03 15:55 UTC, Mick Ohrberg
no flags Details
File: open_fds (208 bytes, text/plain)
2013-07-03 15:55 UTC, Mick Ohrberg
no flags Details
File: proc_pid_status (942 bytes, text/plain)
2013-07-03 15:55 UTC, Mick Ohrberg
no flags Details
File: var_log_messages (638 bytes, text/plain)
2013-07-03 15:55 UTC, Mick Ohrberg
no flags Details

Description Mick Ohrberg 2013-07-03 15:54:46 UTC
Description of problem:
Plug in 4th gen iPod Touch 32GB (silver) to USB port. Reproducible every time.

Version-Release number of selected component:
ifuse-1.1.2-4.fc19

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        ifuse -u a9e05d90b8cb1069546c52af15712a7126a68d91 -ofsname=afc://a9e05d90b8cb1069546c52af15712a7126a68d91 /tmp/kde-mohrberg/amarok/imobiledevice_uuid_a9e05d90b8cb1069546c52af15712a7126a68d91
crash_function: afc_client_new
executable:     /usr/bin/ifuse
kernel:         3.9.8-300.fc19.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
Thread no. 1 (6 frames)
 #0 afc_client_new at afc.c:126
 #1 ifuse_init at ifuse.c:405
 #2 fuse_fs_init at fuse.c:2590
 #3 do_init at fuse_lowlevel.c:1835
 #4 fuse_ll_process_buf at fuse_lowlevel.c:2441
 #5 fuse_do_work at fuse_loop_mt.c:117

Comment 1 Mick Ohrberg 2013-07-03 15:54:50 UTC
Created attachment 768313 [details]
File: backtrace

Comment 2 Mick Ohrberg 2013-07-03 15:54:55 UTC
Created attachment 768314 [details]
File: cgroup

Comment 3 Mick Ohrberg 2013-07-03 15:55:00 UTC
Created attachment 768315 [details]
File: core_backtrace

Comment 4 Mick Ohrberg 2013-07-03 15:55:06 UTC
Created attachment 768316 [details]
File: dso_list

Comment 5 Mick Ohrberg 2013-07-03 15:55:09 UTC
Created attachment 768317 [details]
File: environ

Comment 6 Mick Ohrberg 2013-07-03 15:55:13 UTC
Created attachment 768318 [details]
File: limits

Comment 7 Mick Ohrberg 2013-07-03 15:55:17 UTC
Created attachment 768319 [details]
File: maps

Comment 8 Mick Ohrberg 2013-07-03 15:55:20 UTC
Created attachment 768320 [details]
File: open_fds

Comment 9 Mick Ohrberg 2013-07-03 15:55:22 UTC
Created attachment 768321 [details]
File: proc_pid_status

Comment 10 Mick Ohrberg 2013-07-03 15:55:25 UTC
Created attachment 768322 [details]
File: var_log_messages

Comment 11 qman_44 2013-07-11 17:45:52 UTC
I tried to mount my ipod with "ifuse /mnt/ipod --root"
I have an ipod touch 1g, 16gb with IOS 3.1.3 jailbroken.

reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        ifuse -u d2457a11a5a4f6fd2a92ba830e0e357138b249cb -ofsname=afc://d2457a11a5a4f6fd2a92ba830e0e357138b249cb /tmp/kde-aaron/amarok/imobiledevice_uuid_d2457a11a5a4f6fd2a92ba830e0e357138b249cb
crash_function: afc_client_new
executable:     /usr/bin/ifuse
kernel:         3.9.9-301.fc19.x86_64
package:        ifuse-1.1.2-4.fc19
reason:         Process /usr/bin/ifuse was killed by signal 11 (SIGSEGV)
runlevel:       N 5
uid:            1000

Comment 12 Mick Ohrberg 2013-08-23 13:50:14 UTC
Plugging in 4th gen iPod Touch (32G silver), then starting Amarok.

reporter:       libreport-2.1.6
backtrace_rating: 4
cmdline:        ifuse -u a9e05d90b8cb1069546c52af15712a7126a68d91 -ofsname=afc://a9e05d90b8cb1069546c52af15712a7126a68d91 /tmp/kde-mohrberg/amarok/imobiledevice_uuid_a9e05d90b8cb1069546c52af15712a7126a68d91
crash_function: afc_client_new
executable:     /usr/bin/ifuse
kernel:         3.10.7-200.fc19.x86_64
package:        ifuse-1.1.2-4.fc19
reason:         Process /usr/bin/ifuse was killed by signal 11 (SIGSEGV)
runlevel:       N 5
uid:            1000

Comment 13 Christophe Fergeau 2013-09-18 08:50:20 UTC
(In reply to Mick Ohrberg from comment #0)
>  #0 afc_client_new at afc.c:126

afc_client_new() ABI changed in libimobiledevice 1.1.5, but the package was only rebuilt, the call to afc_client_new() was not adjusted to the new ABI. Upstream patch is at http://cgit.sukimashita.com/ifuse.git/commit/?id=9ac32aa3cb2ed5242c0fe3c58ef5f571bf2b95d7

Comment 14 Peter Robinson 2013-09-19 03:26:51 UTC
*** Bug 1009337 has been marked as a duplicate of this bug. ***

Comment 15 Fedora Update System 2013-09-19 04:34:56 UTC
ifuse-1.1.2-6.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/ifuse-1.1.2-6.fc20

Comment 16 Fedora Update System 2013-09-19 04:35:06 UTC
ifuse-1.1.2-6.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/ifuse-1.1.2-6.fc19

Comment 17 Fedora Update System 2013-09-19 18:33:41 UTC
Package ifuse-1.1.2-6.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ifuse-1.1.2-6.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-17147/ifuse-1.1.2-6.fc20
then log in and leave karma (feedback).

Comment 18 Mick Ohrberg 2013-09-24 15:28:16 UTC
I did the following on my F19 box:

# su -c 'yum update --enablerepo=updates-testing ifuse-1.1.2-6.fc19'

which did indeed install ifuse 1.1.2-6, but alas! to no avail. When starting amarok, ABRT still pops up with the same issue. This is on kernel 3.11.1-200. Doing:

# ifuse /mnt

seems to work, but when I do

# ls /mnt

I get

ls: cannot access /mnt: Transport endpoint is not connected

Comment 19 Fedora Update System 2013-09-29 01:43:58 UTC
ifuse-1.1.2-6.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2013-09-29 01:45:23 UTC
ifuse-1.1.2-6.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 21 raphael.brandis 2013-10-06 13:09:31 UTC
For me and apparently for others too, the same crash still occurs with ifuse-1.1.2-6.fc19:
https://retrace.fedoraproject.org/faf/reports/194164/

Comment 22 Christophe Fergeau 2013-10-07 07:16:38 UTC
A call to autoreconf -fi seems to be missing from the .spec, which means the code detecting a newer libimobiledevice is never triggered.

Comment 23 Peter Robinson 2013-10-08 16:17:01 UTC
(In reply to Christophe Fergeau from comment #22)
> A call to autoreconf -fi seems to be missing from the .spec, which means the
> code detecting a newer libimobiledevice is never triggered.

My bad, I should have picked that up. Respinning again

Comment 24 Fedora Update System 2013-10-08 19:18:27 UTC
ifuse-1.1.2-7.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/ifuse-1.1.2-7.fc20

Comment 25 Fedora Update System 2013-10-08 19:18:38 UTC
ifuse-1.1.2-7.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/ifuse-1.1.2-7.fc19

Comment 26 Fedora Update System 2013-10-09 14:13:30 UTC
Package ifuse-1.1.2-7.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ifuse-1.1.2-7.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18512/ifuse-1.1.2-7.fc20
then log in and leave karma (feedback).

Comment 27 Mick Ohrberg 2013-10-10 13:35:08 UTC
Fix appears to work. Left karma/feedback on the fc19 package.

Comment 28 Fedora Update System 2013-10-13 19:52:04 UTC
ifuse-1.1.2-7.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 29 Fedora Update System 2013-10-18 19:45:02 UTC
ifuse-1.1.2-7.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.