Bug 980978 - RuntimeError: cannot join thread before it is started
RuntimeError: cannot join thread before it is started
Status: CLOSED DUPLICATE of bug 970858
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:e6c446f37890a346f63229a342f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 13:53 EDT by Chris Gilligan
Modified: 2013-11-15 10:02 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-15 10:02:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: anaconda-tb (259.27 KB, text/plain)
2013-07-03 13:53 EDT, Chris Gilligan
no flags Details
File: anaconda.log (6.88 KB, text/plain)
2013-07-03 13:53 EDT, Chris Gilligan
no flags Details
File: environ (441 bytes, text/plain)
2013-07-03 13:53 EDT, Chris Gilligan
no flags Details
File: lsblk_output (1.01 KB, text/plain)
2013-07-03 13:53 EDT, Chris Gilligan
no flags Details
File: nmcli_dev_list (3.45 KB, text/plain)
2013-07-03 13:54 EDT, Chris Gilligan
no flags Details

  None (edit)
Description Chris Gilligan 2013-07-03 13:53:43 EDT
Description of problem:
installing on virtualbox

Version-Release number of selected component:
anaconda-19.30.13-1

The following was filed automatically by anaconda:
anaconda 19.30.13-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/threading.py", line 939, in join
    raise RuntimeError("cannot join thread before it is started")
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 85, in wait
    self.get(name).join()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 649, in _initialize
    threadMgr.wait(constants.THREAD_CUSTOM_STORAGE_INIT)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
RuntimeError: cannot join thread before it is started

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19
Comment 1 Chris Gilligan 2013-07-03 13:53:47 EDT
Created attachment 768364 [details]
File: anaconda-tb
Comment 2 Chris Gilligan 2013-07-03 13:53:51 EDT
Created attachment 768365 [details]
File: anaconda.log
Comment 3 Chris Gilligan 2013-07-03 13:53:54 EDT
Created attachment 768366 [details]
File: environ
Comment 4 Chris Gilligan 2013-07-03 13:53:57 EDT
Created attachment 768367 [details]
File: lsblk_output
Comment 5 Chris Gilligan 2013-07-03 13:54:01 EDT
Created attachment 768368 [details]
File: nmcli_dev_list
Comment 6 Chris Lumens 2013-11-15 10:02:04 EST

*** This bug has been marked as a duplicate of bug 970858 ***

Note You need to log in before you can comment on or make changes to this bug.