Bug 970858 - Installation on a system with one CPU fails with anaconda exception
Installation on a system with one CPU fails with anaconda exception
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
s390x All
unspecified Severity urgent
: ---
: ---
Assigned To: Martin Kolman
Fedora Extras Quality Assurance
:
: 980978 1002542 (view as bug list)
Depends On:
Blocks: ZedoraTracker
  Show dependency treegraph
 
Reported: 2013-06-05 02:20 EDT by IBM Bug Proxy
Modified: 2014-04-14 12:44 EDT (History)
13 users (show)

See Also:
Fixed In Version: anaconda-21.7-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-14 12:44:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda-tb (284.02 KB, text/plain)
2013-06-05 02:21 EDT, IBM Bug Proxy
no flags Details
syslog (37.95 KB, text/plain)
2013-06-05 02:21 EDT, IBM Bug Proxy
no flags Details
Packaging.log (302.91 KB, text/plain)
2013-06-05 02:21 EDT, IBM Bug Proxy
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
IBM Linux Technology Center 94296 None None None Never

  None (edit)
Description IBM Bug Proxy 2013-06-05 02:20:51 EDT
Steps to recreate the problem:
--------------------------------------------------
1) Start installation(ftp based) of Fedora 19 on an LPAR.
2) Select language and hit continue.

Installation fails with following anaconda exception :

anaconda 19.30-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/threading.py", line 939, in join
    raise RuntimeError("cannot join thread before it is started")
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 85, in wait
    self.get(name).join()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/storage.py", line 646, in _initialize
    threadMgr.wait(constants.THREAD_CUSTOM_STORAGE_INIT)
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
RuntimeError: cannot join thread before it is started

Local variables in innermost frame:
self: <AnacondaThread(AnaCustomStorageInit, started daemon 4397718903056)>
balancing: True
timeout: None

Similar installation on a zVM works without any problems.
Comment 1 IBM Bug Proxy 2013-06-05 02:21:12 EDT
Created attachment 757051 [details]
anaconda-tb
Comment 2 IBM Bug Proxy 2013-06-05 02:21:25 EDT
Created attachment 757052 [details]
syslog
Comment 3 IBM Bug Proxy 2013-06-05 02:21:40 EDT
Created attachment 757053 [details]
Packaging.log
Comment 4 IBM Bug Proxy 2013-06-06 04:11:30 EDT
------- Comment From ssant@in.ibm.com 2013-06-06 08:03 EDT-------
The failure depends on number of CPUS. I had single CPU configured for the LPAR during installation. If i increase the number of CPUs, I am able to install without any problem.

Same problem can be recreated on a zVM guest as well if number of CPU is one.
Comment 5 Jan Stodola 2013-06-06 10:13:28 EDT
I was able to reproduce in /zVM on a guest with one CPU, but it doesn't happen every time - about 10% of installations fails.
Comment 6 Jan Stodola 2013-06-06 10:42:53 EDT
And now also reproduced on a z/VM guest with 2 CPUs.
Comment 7 Jan Stodola 2013-07-04 07:39:00 EDT
This issue has also been reported against F19/x86_64, see bug 980978.
Comment 8 Chris Lumens 2013-11-15 10:01:34 EST
Martin's got a patch for this.
Comment 9 Chris Lumens 2013-11-15 10:02:04 EST
*** Bug 980978 has been marked as a duplicate of this bug. ***
Comment 10 Chris Lumens 2013-11-15 10:02:07 EST
*** Bug 1002542 has been marked as a duplicate of this bug. ***
Comment 11 Martin Kolman 2013-11-18 10:52:56 EST
Add correct rawhide version.

Note You need to log in before you can comment on or make changes to this bug.