Bug 981036 - [abrt] evolution-data-server-3.8.3-1.fc19: g_thread_abort: Process /usr/libexec/evolution-source-registry was killed by signal 6 (SIGABRT) [NEEDINFO]
[abrt] evolution-data-server-3.8.3-1.fc19: g_thread_abort: Process /usr/libex...
Status: CLOSED DUPLICATE of bug 1026925
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
abrt_hash:9b236422e0ba7a27f0732184d4f...
:
: 981297 1015785 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 16:28 EDT by korolev.srg
Modified: 2013-11-05 13:06 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-05 13:06:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mcrha: needinfo? (korolev.srg)


Attachments (Terms of Use)
File: backtrace (61.84 KB, text/plain)
2013-07-03 16:28 EDT, korolev.srg
no flags Details
File: cgroup (140 bytes, text/plain)
2013-07-03 16:28 EDT, korolev.srg
no flags Details
File: core_backtrace (3.27 KB, text/plain)
2013-07-03 16:28 EDT, korolev.srg
no flags Details
File: dso_list (16.48 KB, text/plain)
2013-07-03 16:28 EDT, korolev.srg
no flags Details
File: environ (1.07 KB, text/plain)
2013-07-03 16:28 EDT, korolev.srg
no flags Details
File: limits (1.29 KB, text/plain)
2013-07-03 16:28 EDT, korolev.srg
no flags Details
File: maps (79.22 KB, text/plain)
2013-07-03 16:28 EDT, korolev.srg
no flags Details
File: open_fds (1.28 KB, text/plain)
2013-07-03 16:28 EDT, korolev.srg
no flags Details
File: proc_pid_status (955 bytes, text/plain)
2013-07-03 16:28 EDT, korolev.srg
no flags Details

  None (edit)
Description korolev.srg 2013-07-03 16:28:19 EDT
Version-Release number of selected component:
evolution-data-server-3.8.3-1.fc19

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        /usr/libexec/evolution-source-registry
crash_function: g_thread_abort
executable:     /usr/libexec/evolution-source-registry
kernel:         3.9.8-300.fc19.x86_64
runlevel:       N 5
uid:            1000
var_log_messages: Jul  3 23:46:41 edge abrt[3507]: Saved core dump of pid 1711 (/usr/libexec/evolution-source-registry) to /var/tmp/abrt/ccpp-2013-07-03-23:46:40-1711 (153423872 bytes)
xsession_errors: 

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 g_thread_abort at gthread-posix.c:76
 #3 g_mutex_lock at gthread-posix.c:211
 #4 on_notify_g_name_owner at gdbusobjectmanagerclient.c:1232
 #10 g_object_notify_by_spec_internal at gobject.c:1136
 #11 g_object_notify at gobject.c:1178
 #12 on_name_owner_changed at gdbusproxy.c:1363
 #13 emit_signal_instance_in_idle_cb at gdbusconnection.c:3715
 #18 dbus_server_run_server at e-dbus-server.c:222
 #19 ffi_call_unix64 at ../src/x86/unix64.S:76
 #20 ffi_call at ../src/x86/ffi64.c:522
Comment 1 korolev.srg 2013-07-03 16:28:23 EDT
Created attachment 768445 [details]
File: backtrace
Comment 2 korolev.srg 2013-07-03 16:28:26 EDT
Created attachment 768446 [details]
File: cgroup
Comment 3 korolev.srg 2013-07-03 16:28:29 EDT
Created attachment 768447 [details]
File: core_backtrace
Comment 4 korolev.srg 2013-07-03 16:28:32 EDT
Created attachment 768448 [details]
File: dso_list
Comment 5 korolev.srg 2013-07-03 16:28:35 EDT
Created attachment 768449 [details]
File: environ
Comment 6 korolev.srg 2013-07-03 16:28:39 EDT
Created attachment 768450 [details]
File: limits
Comment 7 korolev.srg 2013-07-03 16:28:42 EDT
Created attachment 768451 [details]
File: maps
Comment 8 korolev.srg 2013-07-03 16:28:45 EDT
Created attachment 768452 [details]
File: open_fds
Comment 9 korolev.srg 2013-07-03 16:28:48 EDT
Created attachment 768453 [details]
File: proc_pid_status
Comment 10 Milan Crha 2013-07-04 04:14:48 EDT
Thanks for a bug report. I do not see from the backtrace what could cause the crash, unfortunately, the main thing it shows is a failed call of "pthread_mutex_lock()", on which the g_mutext_lock() function aborts. This is done in the main thread, which responds on a DBus' name-owner-changed signal, which is usually done on some other service, or this one itself, when it's either closed or replaced by other instance on the DBus. Other threads are waiting for a password prompt, and there is quite few of these, waiting to be served.

In any case, was this just an intermittent crash, or you can reproduce this reliably, please? The reproducibility is the main key to be able to investigate the issue properly.
Comment 11 Milan Crha 2013-07-08 05:31:51 EDT
*** Bug 981297 has been marked as a duplicate of this bug. ***
Comment 12 Milan Crha 2013-10-07 06:17:49 EDT
*** Bug 1015785 has been marked as a duplicate of this bug. ***
Comment 13 Milan Crha 2013-11-05 13:06:19 EST

*** This bug has been marked as a duplicate of bug 1026925 ***

Note You need to log in before you can comment on or make changes to this bug.