Bug 98110 - Anaconda installs bad nvidia driver, hangs when starting X11
Anaconda installs bad nvidia driver, hangs when starting X11
Status: CLOSED DUPLICATE of bug 88360
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-26 14:30 EDT by Olivier Byrde
Modified: 2007-04-18 12:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:56:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Olivier Byrde 2003-06-26 14:30:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; (R1 1.3))

Description of problem:
Anaconda correctly detects nvidia geforce 4 video card during install, but then 
is unable to start X11. The GUI shows only a black screen -- no error message.

Installing in text mode doesn't help: when all packages have been installed, 
Anaconda again correctly detects the video card, and installs the same (bad) 
nvidia driver. After a clean install and reboot, the system hangs with the same 
black screen. Switching to TTY (ctrl-alt-f1) doesn't work, the system must be 
hard-rebooted.

This problem happens with GeForce 4 Ti 4200 or 4600 (Asus) connected to LCD 
display (Eizo L565) via DVI. Red Hat 8.0 did install without any problem on the 
same systems.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot from Red Hat Linux 9 CD
2. Wait until anaconda starts X11

    

Actual Results:  System apparently hangs.
In fact the system must be running (disk activity) but the X11 screen remains 
just plain black (no cursor, nothing).
It looks like the nv driver supplied on the install CD is broken.

Expected Results:  Anaconda should start X11 and continue in graphic mode.

Additional info:

Fix:
- boot from CD in rescue mode (text, of course)
- change the "nv" driver in XF86config to "vesa" (for example)
- reboot (X11 starts OK)
- download and install latest driver from www.nvidia.com
Comment 1 Mike A. Harris 2003-06-28 01:52:39 EDT
The "nv" driver included with Red Hat Linux, contains *experimental only*
support for digital flat panel displays.  It is known to have issues, and is
not officially supported by Red Hat.

In order to fix bugs in the "nv" driver, requires access to the specific video
card causing the problem, as well as access to the detailed technical
specifications for the video hardware from the manufacturer, and a knowledge
of how the hardware works.

Nvidia does not provide anyone with the necessary hardware specifications
neither publically nor under NDA with which are necessary to debug and
troubleshoot issues with Nvidia hardware.  Nvidia maintains both the open
source "nv" driver, as well as their proprietary drivers, and only Nvidia
has any knowledge of how their hardware works and how to fix bugs in the
driver.

As such, the majority of problems that arise while using the open source
"nv" driver are not generally fixable unless Nvidia provides patches.  The
"nv" driver is more or less provided as-is, in hopes that it works.  We
are unable to support this driver directly.

Please report this bug upstream to http://bugs.xfree86.org and provide
the URL here in this bug report and I will track the progress on this
issue upstream.  If a simple bug fix is made by Nvidia to XFree86 sources
to solve the problems with flat panels, then they may possibly work in
a future release of Red Hat Linux when the next XFree86 release comes out,
and if patches to fix the specific problems are made available or are
easily extractable from XFree86 CVS once fixed, they might be backportable
for future erratum releases of XFree86 4.3.0 for Red Hat Linux 9.

You may also try using the "vesa" driver as a workaround for this problem
until Nvidia fixes the broken driver.  Alternatively, you may want to try
using the proprietary Nvidia driver from their website, however if you go
this route, you should be aware that Red Hat does not offer support for
systems using proprietary drivers.  See bug #73733 for further details.

Please update this report with your upstream bug URL and I will put this
bug in the tracking state.

Thanks.
Comment 2 Mike A. Harris 2003-07-17 06:52:58 EDT

*** This bug has been marked as a duplicate of 88360 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:56:52 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.