Bug 981193 - [abrt] gnome-online-accounts-3.8.2-1.fc19: Process /usr/libexec/goa-daemon was killed by signal 11 (SIGSEGV)
[abrt] gnome-online-accounts-3.8.2-1.fc19: Process /usr/libexec/goa-daemon wa...
Status: CLOSED DUPLICATE of bug 958336
Product: Fedora
Classification: Fedora
Component: gnome-online-accounts (Show other bugs)
19
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
abrt_hash:03fbd3a3213bf26dc0a9138b9bb...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-04 04:55 EDT by Mikhail
Modified: 2014-09-18 07:38 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-18 07:38:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (36.63 KB, text/plain)
2013-07-04 04:55 EDT, Mikhail
no flags Details
File: cgroup (140 bytes, text/plain)
2013-07-04 04:55 EDT, Mikhail
no flags Details
File: core_backtrace (662 bytes, text/plain)
2013-07-04 04:55 EDT, Mikhail
no flags Details
File: dso_list (11.30 KB, text/plain)
2013-07-04 04:55 EDT, Mikhail
no flags Details
File: environ (928 bytes, text/plain)
2013-07-04 04:55 EDT, Mikhail
no flags Details
File: limits (1.29 KB, text/plain)
2013-07-04 04:55 EDT, Mikhail
no flags Details
File: maps (34.26 KB, text/plain)
2013-07-04 04:55 EDT, Mikhail
no flags Details
File: open_fds (1.13 KB, text/plain)
2013-07-04 04:55 EDT, Mikhail
no flags Details
File: proc_pid_status (787 bytes, text/plain)
2013-07-04 04:56 EDT, Mikhail
no flags Details

  None (edit)
Description Mikhail 2013-07-04 04:55:22 EDT
Version-Release number of selected component:
gnome-online-accounts-3.8.2-1.fc19

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 3
cmdline:        /usr/libexec/goa-daemon
executable:     /usr/libexec/goa-daemon
kernel:         3.9.8-300.fc19.i686
runlevel:       N 5
uid:            1000
var_log_messages: Jul  3 15:45:22 localhost kernel: [26328.796703] goa-daemon[1083]: segfault at 6e6f6d65 ip 6e6f6d65 sp bfab910c error 4

Truncated backtrace:
Thread no. 1 (3 frames)
 #0 ??
 #1 xmlOutputBufferClose__internal_alias at xmlIO.c:2592
 #2 ews_client_autodiscover_data_free at goaewsclient.c:105
Comment 1 Mikhail 2013-07-04 04:55:27 EDT
Created attachment 768652 [details]
File: backtrace
Comment 2 Mikhail 2013-07-04 04:55:32 EDT
Created attachment 768653 [details]
File: cgroup
Comment 3 Mikhail 2013-07-04 04:55:37 EDT
Created attachment 768654 [details]
File: core_backtrace
Comment 4 Mikhail 2013-07-04 04:55:41 EDT
Created attachment 768655 [details]
File: dso_list
Comment 5 Mikhail 2013-07-04 04:55:44 EDT
Created attachment 768656 [details]
File: environ
Comment 6 Mikhail 2013-07-04 04:55:48 EDT
Created attachment 768657 [details]
File: limits
Comment 7 Mikhail 2013-07-04 04:55:52 EDT
Created attachment 768658 [details]
File: maps
Comment 8 Mikhail 2013-07-04 04:55:59 EDT
Created attachment 768659 [details]
File: open_fds
Comment 9 Mikhail 2013-07-04 04:56:03 EDT
Created attachment 768660 [details]
File: proc_pid_status
Comment 10 Matthias Clasen 2013-07-23 09:39:13 EDT
This crash is in the goa module in evolution-data-server
Comment 11 Matthew Barnes 2013-07-23 10:35:28 EDT
Are you sure?

Thread 9 shows calls from goaexchangeprovider.c and goaprovider.c.  I thought the GOA providers run in goa-daemon, as comment #0 indicates.

GOA did copy code from Evolution-EWS for auto-discovery, iirc.
Comment 12 Matthias Clasen 2013-07-23 11:09:51 EDT
Oh, that would explain why I found the code that looked relevant to the crash when grepping in e-d-s. Moving back...
Comment 13 Debarshi Ray 2014-09-18 07:38:26 EDT

*** This bug has been marked as a duplicate of bug 958336 ***

Note You need to log in before you can comment on or make changes to this bug.