Bug 981318 - File rename creates a new file with same name on windows client
File rename creates a new file with same name on windows client
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: samba (Show other bugs)
2.1
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Raghavendra Talur
surabhi
: TestBlocker
Depends On:
Blocks: 956495 990410
  Show dependency treegraph
 
Reported: 2013-07-04 08:59 EDT by Ujjwala
Modified: 2013-09-23 18:29 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.15rhs
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 990410 (view as bug list)
Environment:
Last Closed: 2013-09-23 18:29:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of the windows explorer window (6.17 KB, image/png)
2013-07-04 08:59 EDT, Ujjwala
no flags Details

  None (edit)
Description Ujjwala 2013-07-04 08:59:42 EDT
Created attachment 768797 [details]
screenshot of the windows explorer window

Description of problem:
On the windows client, when you rename a file and save it, it creates a new file.
While the new file shows the correct size, the old file is a 0Kb file.


Version-Release number of selected component (if applicable):
glusterfs 3.4.0.12rhs.beta1

How reproducible:
Always

Steps to Reproduce:
1. Create a distribute volume.
2.Create a Samba-VFS share for the distribute volume in the /etc/samba/smb.conf file.
3. Map the share on the windows client. Create some files.
4. Access the share via windows explorer, right click -> New -> New Text document.
5. A new text file is created, rename the file say abc.txt. Open the file and edit it and save the file. A new file is created with the same name.  

Actual results:
While the new file shows the actual size of the file, the old file is a 0Kb file.

Expected results:
should not create a new file. The same file should be updated.

Additional info:
Comment 5 surabhi 2013-08-07 04:40:02 EDT
The bug is verified in the version glusterfs-3.4.0.16rhs-1.el6rhs.x86_64.
Comment 7 Scott Haines 2013-09-23 18:29:50 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.