Bug 990410 - File rename creates a new file with same name on windows client
File rename creates a new file with same name on windows client
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: gluster-smb (Show other bugs)
pre-release
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Raghavendra Talur
: TestBlocker
Depends On: 981318
Blocks: 956495
  Show dependency treegraph
 
Reported: 2013-07-31 02:57 EDT by Raghavendra Talur
Modified: 2014-04-17 07:44 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 981318
Environment:
Last Closed: 2014-04-17 07:44:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-07-31 02:59:17 EDT
REVIEW: http://review.gluster.org/5440 (dht: make linkfile creation mode explicitly get set) posted (#1) for review on master by Anand Avati (avati@redhat.com)
Comment 2 Anand Avati 2013-07-31 12:03:29 EDT
REVIEW: http://review.gluster.org/5447 (gfapi: perform open() on pre-existing inode in glfs_creat()) posted (#1) for review on master by Anand Avati (avati@redhat.com)
Comment 3 Anand Avati 2013-07-31 16:30:26 EDT
COMMIT: http://review.gluster.org/5447 committed in master by Anand Avati (avati@redhat.com) 
------
commit dfedfec3593ca0fc026d8a094916824e1b90e60b
Author: Anand Avati <avati@redhat.com>
Date:   Mon Jul 22 10:02:34 2013 -0700

    gfapi: perform open() on pre-existing inode in glfs_creat()
    
    Performing syncop_create() on a pre-existing file can result
    in opening the linkfile if DHT has a linkfile for the file.
    This is because dht_create() will perform the op on the
    hashed_subvol() and overwrite the layout in dht_create_cbk.
    
    Change-Id: I7a0db56921ec9fc3e278e0418db3b967f81e5598
    BUG: 990410
    Signed-off-by: Anand Avati <avati@redhat.com>
    Reviewed-on: http://review.gluster.org/5447
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    Tested-by: Raghavendra Talur <rtalur@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 4 Anand Avati 2013-07-31 16:32:08 EDT
COMMIT: http://review.gluster.org/5440 committed in master by Anand Avati (avati@redhat.com) 
------
commit 394055e31f3c90701336c84aafa7d3ab1e313c65
Author: Anand Avati <avati@redhat.com>
Date:   Mon Jul 22 01:26:43 2013 -0700

    dht: make linkfile creation mode explicitly get set
    
    Because of posix default_acl on parent directory, the mode
    of linkfile can get masked with the mode in the default acl.
    
    This breaks DHT integrity. So let the mode get explicitly reset
    after mknod().
    
    Change-Id: Ia7328e1ee7b4430bda308f9da293dba78405e081
    BUG: 990410
    Signed-off-by: Anand Avati <avati@redhat.com>
    Reviewed-on: http://review.gluster.org/5440
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
Comment 5 Anand Avati 2013-09-09 20:56:38 EDT
REVIEW: http://review.gluster.org/5884 (gfapi: perform open() on pre-existing inode in glfs_creat()) posted (#1) for review on release-3.4 by Anand Avati (avati@redhat.com)
Comment 6 Anand Avati 2013-09-09 21:12:01 EDT
REVIEW: http://review.gluster.org/5884 (gfapi: perform open() on pre-existing inode in glfs_creat()) posted (#2) for review on release-3.4 by Anand Avati (avati@redhat.com)
Comment 7 Anand Avati 2013-09-10 04:26:07 EDT
COMMIT: http://review.gluster.org/5884 committed in release-3.4 by Vijay Bellur (vbellur@redhat.com) 
------
commit 2cd2532e149847771319ad56b8b745f0f38c0bd4
Author: Anand Avati <avati@redhat.com>
Date:   Mon Jul 22 10:02:34 2013 -0700

    gfapi: perform open() on pre-existing inode in glfs_creat()
    
    Performing syncop_create() on a pre-existing file can result
    in opening the linkfile if DHT has a linkfile for the file.
    This is because dht_create() will perform the op on the
    hashed_subvol() and overwrite the layout in dht_create_cbk.
    
    Change-Id: I7a0db56921ec9fc3e278e0418db3b967f81e5598
    BUG: 990410
    Signed-off-by: Anand Avati <avati@redhat.com>
    Reviewed-on: http://review.gluster.org/5884
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 9 Niels de Vos 2014-04-17 07:44:44 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.