Bug 981450 - SELinux is preventing /usr/bin/df from 'getattr' accesses on the directory /proc/sys/fs/binfmt_misc.
Summary: SELinux is preventing /usr/bin/df from 'getattr' accesses on the directory /p...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 19
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:cf2742b59293b0e1b4771e96bd9...
: 981451 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-04 18:43 UTC by Mark
Modified: 2013-07-14 03:39 UTC (History)
3 users (show)

Fixed In Version: selinux-policy-3.12.1-63.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-07-14 03:39:11 UTC
Type: ---


Attachments (Terms of Use)

Description Mark 2013-07-04 18:43:28 UTC
Description of problem:
SELinux is preventing /usr/bin/df from 'getattr' accesses on the directory /proc/sys/fs/binfmt_misc.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that df should be allowed getattr access on the binfmt_misc directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep df /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:rabbitmq_beam_t:s0
Target Context                system_u:object_r:autofs_t:s0
Target Objects                /proc/sys/fs/binfmt_misc [ dir ]
Source                        df
Source Path                   /usr/bin/df
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           coreutils-8.21-11.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-54.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.8-300.fc19.x86_64 #1 SMP Thu
                              Jun 27 19:24:23 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-07-04 00:47:25 EDT
Last Seen                     2013-07-04 00:47:25 EDT
Local ID                      fff5b4d4-f2e5-41ff-ab2f-6ef3a2f3de91

Raw Audit Messages
type=AVC msg=audit(1372913245.964:863): avc:  denied  { getattr } for  pid=6146 comm="df" path="/proc/sys/fs/binfmt_misc" dev="autofs" ino=9491 scontext=system_u:system_r:rabbitmq_beam_t:s0 tcontext=system_u:object_r:autofs_t:s0 tclass=dir


type=SYSCALL msg=audit(1372913245.964:863): arch=x86_64 syscall=stat success=no exit=EACCES a0=1b77310 a1=7fff47b424e0 a2=7fff47b424e0 a3=0 items=0 ppid=6143 pid=6146 auid=4294967295 uid=992 gid=991 euid=992 suid=992 fsuid=992 egid=991 sgid=991 fsgid=991 ses=4294967295 tty=(none) comm=df exe=/usr/bin/df subj=system_u:system_r:rabbitmq_beam_t:s0 key=(null)

Hash: df,rabbitmq_beam_t,autofs_t,dir,getattr

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.9.8-300.fc19.x86_64
type:           libreport

Comment 1 Miroslav Grepl 2013-07-07 06:53:06 UTC
*** Bug 981451 has been marked as a duplicate of this bug. ***

Comment 2 Miroslav Grepl 2013-07-07 06:54:52 UTC
commit efa05c32ac606d8ee7f0ba205ca156dee3406496
Author: Miroslav Grepl <mgrepl@redhat.com>
Date:   Sun Jul 7 08:54:16 2013 +0200

    Allow rabbitmq_beam_t to getattr on all filesystems

Comment 3 Fedora Update System 2013-07-11 08:58:09 UTC
selinux-policy-3.12.1-63.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/selinux-policy-3.12.1-63.fc19

Comment 4 Fedora Update System 2013-07-12 02:57:40 UTC
Package selinux-policy-3.12.1-63.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.12.1-63.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12762/selinux-policy-3.12.1-63.fc19
then log in and leave karma (feedback).

Comment 5 Mark 2013-07-13 06:13:10 UTC
Description of problem:
start riak

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.9.9-301.fc19.x86_64
type:           libreport

Comment 6 Fedora Update System 2013-07-14 03:39:11 UTC
selinux-policy-3.12.1-63.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.