Bug 981451 - SELinux is preventing /usr/bin/df from 'getattr' accesses on the filesystem /sys/fs/cgroup/perf_event.
SELinux is preventing /usr/bin/df from 'getattr' accesses on the filesystem /...
Status: CLOSED DUPLICATE of bug 981450
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:a5944ab4e4366a9ba11c5c8cba2...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-04 14:44 EDT by Mark
Modified: 2013-07-07 02:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-07 02:53:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark 2013-07-04 14:44:57 EDT
Description of problem:
SELinux is preventing /usr/bin/df from 'getattr' accesses on the filesystem /sys/fs/cgroup/perf_event.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that df should be allowed getattr access on the perf_event filesystem by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep df /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:rabbitmq_beam_t:s0
Target Context                system_u:object_r:cgroup_t:s0
Target Objects                /sys/fs/cgroup/perf_event [ filesystem ]
Source                        df
Source Path                   /usr/bin/df
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           coreutils-8.21-11.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-54.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.8-300.fc19.x86_64 #1 SMP Thu
                              Jun 27 19:24:23 UTC 2013 x86_64 x86_64
Alert Count                   5
First Seen                    2013-07-04 00:47:25 EDT
Last Seen                     2013-07-04 00:47:25 EDT
Local ID                      a7179d2b-9ff5-4455-97ee-6898885eac99

Raw Audit Messages
type=AVC msg=audit(1372913245.976:875): avc:  denied  { getattr } for  pid=6146 comm="df" name="/" dev="cgroup" ino=6974 scontext=system_u:system_r:rabbitmq_beam_t:s0 tcontext=system_u:object_r:cgroup_t:s0 tclass=filesystem


type=SYSCALL msg=audit(1372913245.976:875): arch=x86_64 syscall=statfs success=no exit=EACCES a0=1b771c0 a1=7fff47b41d50 a2=7fff47b420f0 a3=ffffffff items=0 ppid=6143 pid=6146 auid=4294967295 uid=992 gid=991 euid=992 suid=992 fsuid=992 egid=991 sgid=991 fsgid=991 ses=4294967295 tty=(none) comm=df exe=/usr/bin/df subj=system_u:system_r:rabbitmq_beam_t:s0 key=(null)

Hash: df,rabbitmq_beam_t,cgroup_t,filesystem,getattr

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.9.8-300.fc19.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-07-07 02:53:06 EDT

*** This bug has been marked as a duplicate of bug 981450 ***

Note You need to log in before you can comment on or make changes to this bug.