Bug 981668 - quota: E [quotad.c:501:qd_handle_entry] 0-dist-rep: Quota check on (null) failed
quota: E [quotad.c:501:qd_handle_entry] 0-dist-rep: Quota check on (null) failed
Status: CLOSED WORKSFORME
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.1
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: vpshastry
Sudhir D
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-05 08:44 EDT by Saurabh
Modified: 2016-01-19 01:12 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-04 04:50:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saurabh 2013-07-05 08:44:38 EDT
Description of problem:

executing rm -rf * on the mount point, error messages are found in quotad.log


Version-Release number of selected component (if applicable):
[root@quota1 ~]# rpm -qa | grep glusterfs
glusterfs-fuse-3.4.0.12rhs.beta2-1.el6rhs.x86_64
glusterfs-server-3.4.0.12rhs.beta2-1.el6rhs.x86_64
glusterfs-debuginfo-3.4.0.12rhs.beta2-1.el6rhs.x86_64
glusterfs-3.4.0.12rhs.beta2-1.el6rhs.x86_64


How reproducible:
always

Steps to Reproduce:
1. create a volume, start it
2. enable quota and set some limit on the root of the volume
3. mount the volume using nfs
4. create 500 dirs
5. one single sub dir in each of the above created dir
6. set limit for dirs as 2GB
7. set limit for subdir as 1GB
8. rm -rf * on mount point

Actual results:
[2013-07-05 05:49:26.562939] E [quotad.c:501:qd_handle_entry] 0-dist-rep: Quota check on (null) failed
[2013-07-05 05:49:26.565226] W [inode.c:935:inode_forget] (-->/usr/lib64/glusterfs/3.4.0.12rhs.beta2/xlator/features/quotad.so(qd_handle_entry+0x13d) [0x7f01e6180a2d] (-->/usr/lib64/glusterfs/3.4.0.12rhs.beta2/xlator/features/quotad.so(qd_resolve_entry+0x309) [0x7f01e6180889] (-->/usr/lib64/glusterfs/3.4.0.12rhs.beta2/xlator/features/quotad.so(qd_resolve_handle_error+0x72) [0x7f01e617f492]))) 0-quotad: inode not found
[2013-07-05 05:49:26.565252] E [quotad.c:501:qd_handle_entry] 0-dist-rep: Quota check on (null) failed
[2013-07-05 05:49:26.567526] W [inode.c:935:inode_forget] (-->/usr/lib64/glusterfs/3.4.0.12rhs.beta2/xlator/features/quotad.so(qd_handle_entry+0x13d) [0x7f01e6180a2d] (-->/usr/lib64/glusterfs/3.4.0.12rhs.beta2/xlator/features/quotad.so(qd_resolve_entry+0x309) [0x7f01e6180889] (-->/usr/lib64/glusterfs/3.4.0.12rhs.beta2/xlator/features/quotad.so(qd_resolve_handle_error+0x72) [0x7f01e617f492]))) 0-quotad: inode not found
[2013-07-05 05:49:26.567542] E [quotad.c:501:qd_handle_entry] 0-dist-rep: Quota check on (null) failed
[2013-07-05 05:49:26.586597] E [quotad.c:501:qd_handle_entry] 0-dist-rep: Quota check on (null) failed
[2013-07-05 05:49:26.590244] W [inode.c:935:inode_forget] (-->/usr/lib64/glusterfs/3.4.0.12rhs.beta2/xlator/features/quotad.so(qd_handle_entry+0x13d) [0x7f01e6180a2d] (-->/usr/lib64/glusterfs/3.4.0.12rhs.beta2/xlator/features/quotad.so(qd_resolve_entry+0x309) [0x7f01e6180889] (-->/usr/lib64/glusterfs/3.4.0.12rhs.beta2/xlator/features/quotad.so(qd_resolve_handle_error+0x72) [0x7f01e617f492]))) 0-quotad: inode not found
[2013-07-05 05:49:26.590263] E [quotad.c:501:qd_handle_entry] 0-dist-rep: Quota check on (null) failed
[2013-07-05 05:49:26.593530] W [inode.c:935:inode_forget] (-->/usr/lib64/glusterfs/3.4.0.12rhs.beta2/xlator/features/quotad.so(qd_handle_entry+0x13d) [0x7f01e6180a2d] (-->/usr/lib64/glusterfs/3.4.0.12rhs.beta2/xlator/features/quotad.so(qd_resolve_entry+0x309) [0x7f01e6180889] (-->/usr/lib64/glusterfs/3.4.0.12rhs.beta2/xlator/features/quotad.so(qd_resolve_handle_error+0x72) [0x7f01e617f492]))) 0-quotad: inode not found
[2013-07-05 05:49:26.593548] E [quotad.c:501:qd_handle_entry] 0-dist-rep: Quota check on (null) failed
[2013-07-05 05:49:26.596221] W [inode.c:935:inode_forget] (-->/usr/lib64/glusterfs/3.4.0.12rhs.beta2/xlator/features/quotad.so(qd_handle_entry+0x13d) [0x7f01e6180a2d] (-->/usr/lib64/glusterfs/3.4.0.12rhs.beta2/xlator/features/quotad.so(qd_resolve_entry+0x309) [0x7f01e6180889] (-->/usr/lib64/glusterfs/3.4.0.12rhs.beta2/xlator/features/quotad.so(qd_resolve_handle_error+0x72) [0x7f01e617f492]))) 0-quotad: inode not found
[2013-07-05 05:49:26.596235] E [quotad.c:501:qd_handle_entry] 0-dist-rep: Quota check on (null) failed
[2013-07-05 05:49:26.596301] W [dht-layout.c:179:dht_layout_search] 0-dist-rep: no subvolume for hash (value) = 2221416999
^C


Expected results:

it is just a delettion of the data, why does quotad crib?
expected it quotad shouldn't be doing quota check during deletion of data.

Additional info:

BZ 981653
BZ 981661

were filed before this bug.
Comment 4 Amar Tumballi 2013-07-06 13:34:44 EDT
Varun, this has potential to de-rail the debugging session. Can you please check and fix it?
Comment 7 vpshastry 2013-07-16 06:38:30 EDT
CHANGE: https://code.engineering.redhat.com/gerrit/9436 fixes the issue.
Comment 8 vpshastry 2013-09-04 03:38:42 EDT
Since the implementation changed, can you verify with v3.4.0qa8?

Note You need to log in before you can comment on or make changes to this bug.