Bug 981751 - [RFE] No option to specify IPv6 or IPv4 explicitly must be used
[RFE] No option to specify IPv6 or IPv4 explicitly must be used
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: telnet (Show other bugs)
6.6
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Luboš Uhliarik
qe-baseos-daemons
: FutureFeature, Patch
Depends On: 1069809
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-05 13:24 EDT by Peter Robinson
Modified: 2016-08-16 07:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1069809 1367415 (view as bug list)
Environment:
Last Closed: 2016-08-16 07:32:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2013-07-05 13:24:07 EDT
telnet is a very useful low level utility for debugging connections to mail or webservers or other such plain text services. 

A lot of services such as ping and traceroute offer means of forcing either IPv4 or IPv6. EG with traceroute you can add a -4 for explicit IPv4 or -6 or explicit IPv6 against a host. Or you can use traceroute6

Telnet doesn't offer that option so if I wanted to test to see if a mail server was working correctly with IPv6 there is no way I can force it to use IPv6. 

EG: I want to test the if the MX for the skymesh.com.au domain are accepting mail on IPv6 I would do the following:

$ dig skymesh.com.au mx

And get a list of MX records:

;; ANSWER SECTION:
skymesh.com.au.         70      IN      MX      500 mx1.skymesh.com.au.
skymesh.com.au.         70      IN      MX      500 mx1.skymesh.net.au.
skymesh.com.au.         70      IN      MX      500 mx2.skymesh.com.au.
skymesh.com.au.         70      IN      MX      500 mx2.skymesh.net.au.
skymesh.com.au.         70      IN      MX      500 mx3.skymesh.com.au.
skymesh.com.au.         70      IN      MX      500 mx3.skymesh.net.au.
skymesh.com.au.         70      IN      MX      500 mx4.skymesh.com.au.
skymesh.com.au.         70      IN      MX      500 mx4.skymesh.net.au.
skymesh.com.au.         70      IN      MX      500 mx5.skymesh.com.au.

And we find that mx1, mx2 and mx3 have IPv6 records

;; ADDITIONAL SECTION:
mx2.skymesh.com.au.     71      IN      A       180.181.128.97
mx2.skymesh.com.au.     73      IN      AAAA    2401:a400:100:dead::cafe:2
mx3.skymesh.com.au.     74      IN      A       180.181.128.131
mx3.skymesh.com.au.     74      IN      AAAA    2401:a400:100:dead::cafe:3
mx4.skymesh.com.au.     76      IN      A       180.181.192.10
mx5.skymesh.com.au.     81      IN      A       180.181.192.11
mx1.skymesh.com.au.     81      IN      A       180.181.128.96
mx1.skymesh.com.au.     82      IN      AAAA    2401:a400:100:dead::cafe:1

But I can't force IPv6:

$ telnet mx2.skymesh.com.au 25
Trying 180.181.128.97...
Connected to mx2.skymesh.com.au.
Escape character is '^]'.
220 mx2.skymesh.com.au ESMTP (Debian/GNU)

I could try the IPv6 address directly:

$ telnet 2401:a400:100:dead::cafe:2 25
Trying 2401:a400:100:dead::cafe:2...
telnet: connect to address 2401:a400:100:dead::cafe:2: Network is unreachable

but in the case of testing something like a virtual http host we need to be able to actually specify the proper FQDN.
Comment 2 RHEL Product and Program Management 2013-10-13 19:24:40 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 3 Michal Sekletar 2014-02-25 12:00:58 EST
Cloning against Fedora. Let's resolve it there first and then we can consider backporting for RHEL.
Comment 10 Luboš Uhliarik 2016-08-16 07:32:07 EDT
Red Hat Enterprise Linux version 6 is entering the Production 2 phase of its
lifetime and this bug doesn't meet the criteria for it, i.e. only high severity
issues will be fixed. Please see
https://access.redhat.com/support/policy/updates/errata/ for further
information.

This issue is tracked as a bug #1367415 in Red Hat
Enterprise Linux version 7.

Note You need to log in before you can comment on or make changes to this bug.