Bug 981754 - Fedup ignoring packages on NFS mounted drives
Fedup ignoring packages on NFS mounted drives
Status: CLOSED DUPLICATE of bug 987106
Product: Fedora
Classification: Fedora
Component: fedup (Show other bugs)
19
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-05 13:42 EDT by G. Michael Carter
Modified: 2013-10-09 15:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-09 15:50:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description G. Michael Carter 2013-07-05 13:42:27 EDT
I did a fedup upgrade and it forgot to install things like the kernel and gnome-shell.

Just figured out the pattern.  

Seems all the files it was pulling via the automount system are being ignored.  Probably because the autofs system won't be active when the upgrade is happening.

First is a question, is there a flag to pull the packages into /var/tmp/fedora-upgrade regardless where they are?

========================================
CMD: fedup-cli --network 19 --addrepo f19-everything-bk=file:///mnt/autofs/Repositories/i386/f19-everything/ --addrepo f19-update-bk=file:///mnt/autofs/Repositories/i386/f19-updates/ -d

========================================
for x in $(grep add_install /var/log/fedup.log | awk -F"add_install" '{print $3}' | awk -F, '{print $1}' | sed "s/^[(]//g") ; do
 base="$(basename $x)"; 
 if [ -s /system-upgrade/${base} ] then; 
   echo "PASS  : "
 else
   echo "FAIL  : "
 fi
 echo $x; 
done
========================================


[root@fedora-upgrade ~]# ./test.sh
PASS  : /var/tmp/fedora-upgrade/default-installrepo/packages/xorg-x11-drv-openchrome-0.3.3-1.fc19.x86_64.rpm
FAIL  : /mnt/autofs/Repositories/i386/f19-everything/astronomy-backgrounds-1.0-7.fc19.noarch.rpm
PASS  : /var/tmp/fedora-upgrade/default-installrepo/packages/shotwell-0.14.1-1.fc19.x86_64.rpm
PASS  : /var/tmp/fedora-upgrade/default-installrepo/packages/usermode-1.111-3.fc19.x86_64.rpm
PASS  : /var/tmp/fedora-upgrade/default-installrepo/packages/cjkuni-uming-fonts-0.2.20080216.1-52.fc19.noarch.rpm
PASS  : /var/tmp/fedora-upgrade/default-installrepo/packages/audit-libs-python-2.3.1-2.fc19.x86_64.rpm
FAIL  : /mnt/autofs/Repositories/i386/f19-everything/texlive-bibtex-svn26689.0.99d-22.fc19.noarch.rpm
FAIL  : /mnt/autofs/Repositories/i386/f19-everything/cairo-1.12.14-2.fc19.i686.rpm
PASS  : /var/tmp/fedora-upgrade/default-installrepo/packages/device-mapper-persistent-data-0.1.4-3.fc19.x86_64.rpm
PASS  : /var/tmp/fedora-upgrade/default-installrepo/packages/libXt-1.1.4-5.fc19.x86_64.rpm
PASS  : /var/tmp/fedora-upgrade/default-installrepo/packages/evince-nautilus-3.8.2-1.fc19.x86_64.rpm
FAIL  : /mnt/autofs/Repositories/x86_64/f19-rpmfusion-free-base/libmad-0.15.1b-16.fc19.x86_64.rpm
PASS  : /var/tmp/fedora-upgrade/default-installrepo/packages/avahi-ui-gtk3-0.6.31-11.fc19.x86_64.rpm
FAIL  : /mnt/autofs/Repositories/x86_64/f19-updates/gvfs-gphoto2-1.16.3-2.fc19.x86_64.rpm
FAIL  : /mnt/autofs/Repositories/i386/f19-everything/system-config-network-1.6.11-1.fc19.i686.rpm
PASS  : /var/tmp/fedora-upgrade/default-installrepo/packages/nautilus-extensions-3.8.2-1.fc19.x86_64.rpm
FAIL  : /mnt/autofs/Repositories/x86_64/f19-everything/gpaste-3.0.2-1.fc19.x86_64.rpm
FAIL  : /mnt/autofs/Repositories/i386/f19-everything/pcre-8.32-7.fc19.i686.rpm
FAIL  : /mnt/autofs/Repositories/x86_64/f19-everything/avahi-compat-howl-0.6.31-11.fc19.x86_64.rpm
FAIL  : /mnt/autofs/Repositories/i386/f19-everything/texlive-dtxgen-bin-svn29031.0-22.20130427_r30134.fc19.noarch.rpm
PASS  : /var/tmp/fedora-upgrade/default-installrepo/packages/ant-1.8.4-6.fc19.noarch.rpm
PASS  : /var/tmp/fedora-upgrade/default-installrepo/packages/net-snmp-libs-5.7.2-11.fc19.x86_64.rpm
PASS  : /var/tmp/fedora-upgrade/default-installrepo/packages/ftgl-2.1.3-0.8.rc5.fc19.x86_64.rpm
PASS  : /var/tmp/fedora-upgrade/default-installrepo/packages/attr-2.4.46-10.fc19.x86_64.rpm
FAIL  : /mnt/autofs/Repositories/x86_64/f19-everything/texlive-makeindex-bin-svn26509.0-22.20130427_r30134.fc19.x86_64.rpm
PASS  : /var/tmp/fedora-upgrade/default-installrepo/packages/festival-speechtools-libs-1.2.96-25.fc19.x86_64.rpm
PASS  : /var/tmp/fedora-upgrade/default-installrepo/packages/gsettings-desktop-schemas-3.8.2-1.fc19.x86_64.rpm
Comment 1 Will Woods 2013-10-09 15:50:14 EDT

*** This bug has been marked as a duplicate of bug 987106 ***

Note You need to log in before you can comment on or make changes to this bug.