Bug 981890 - [abrt] NetworkManager-0.9.8.2-2.fc19: __pthread_mutex_lock: Process /usr/sbin/NetworkManager was killed by signal 11 (SIGSEGV)
[abrt] NetworkManager-0.9.8.2-2.fc19: __pthread_mutex_lock: Process /usr/sbin...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
abrt_hash:e332b106a8b17f9eb33c4ed4b39...
:
: 989730 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-06 14:41 EDT by marcks14
Modified: 2013-07-30 03:36 EDT (History)
3 users (show)

See Also:
Fixed In Version: NetworkManager-0.9.8.2-8.git20130709.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-11 23:07:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (21.62 KB, text/plain)
2013-07-06 14:41 EDT, marcks14
no flags Details
File: cgroup (174 bytes, text/plain)
2013-07-06 14:41 EDT, marcks14
no flags Details
File: core_backtrace (1.54 KB, text/plain)
2013-07-06 14:41 EDT, marcks14
no flags Details
File: dso_list (1.17 KB, text/plain)
2013-07-06 14:41 EDT, marcks14
no flags Details
File: environ (119 bytes, text/plain)
2013-07-06 14:41 EDT, marcks14
no flags Details
File: limits (1.29 KB, text/plain)
2013-07-06 14:41 EDT, marcks14
no flags Details
File: maps (25.62 KB, text/plain)
2013-07-06 14:41 EDT, marcks14
no flags Details
File: open_fds (2.11 KB, text/plain)
2013-07-06 14:41 EDT, marcks14
no flags Details
File: proc_pid_status (899 bytes, text/plain)
2013-07-06 14:41 EDT, marcks14
no flags Details
File: var_log_messages (11.07 KB, text/plain)
2013-07-06 14:41 EDT, marcks14
no flags Details

  None (edit)
Description marcks14 2013-07-06 14:41:08 EDT
Version-Release number of selected component:
NetworkManager-0.9.8.2-2.fc19

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        /usr/sbin/NetworkManager --no-daemon
crash_function: __pthread_mutex_lock
executable:     /usr/sbin/NetworkManager
kernel:         3.9.5-301.fc19.x86_64
runlevel:       N 5
uid:            0

Truncated backtrace:
Thread no. 1 (6 frames)
 #0 __pthread_mutex_lock at pthread_mutex_lock.c:50
 #1 _dbus_platform_rmutex_lock at dbus-sysdeps-pthread.c:156
 #2 _dbus_rmutex_lock at dbus-threads.c:176
 #3 dbus_connection_add_filter at dbus-connection.c:5480
 #4 dbus_connection_changed_cb at nm-manager.c:4516
 #9 nm_dbus_manager_reconnect at nm-dbus-manager.c:162
Comment 1 marcks14 2013-07-06 14:41:15 EDT
Created attachment 769711 [details]
File: backtrace
Comment 2 marcks14 2013-07-06 14:41:19 EDT
Created attachment 769712 [details]
File: cgroup
Comment 3 marcks14 2013-07-06 14:41:25 EDT
Created attachment 769713 [details]
File: core_backtrace
Comment 4 marcks14 2013-07-06 14:41:29 EDT
Created attachment 769714 [details]
File: dso_list
Comment 5 marcks14 2013-07-06 14:41:32 EDT
Created attachment 769715 [details]
File: environ
Comment 6 marcks14 2013-07-06 14:41:36 EDT
Created attachment 769716 [details]
File: limits
Comment 7 marcks14 2013-07-06 14:41:41 EDT
Created attachment 769717 [details]
File: maps
Comment 8 marcks14 2013-07-06 14:41:44 EDT
Created attachment 769718 [details]
File: open_fds
Comment 9 marcks14 2013-07-06 14:41:47 EDT
Created attachment 769719 [details]
File: proc_pid_status
Comment 10 marcks14 2013-07-06 14:41:51 EDT
Created attachment 769720 [details]
File: var_log_messages
Comment 11 Jirka Klimes 2013-07-09 11:37:26 EDT
It's been fixed upstream:
http://cgit.freedesktop.org/NetworkManager/NetworkManager/commit/?h=nm-0-9-8&id=3172ff1015b799d41e220dc786d21744fc6af70e

The change will propagate into Fedora in the next update.
Comment 12 Fedora Update System 2013-07-09 12:27:09 EDT
NetworkManager-0.9.8.2-8.git20130709.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/NetworkManager-0.9.8.2-8.git20130709.fc19
Comment 13 Fedora Update System 2013-07-09 21:21:25 EDT
Package NetworkManager-0.9.8.2-8.git20130709.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-0.9.8.2-8.git20130709.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12651/NetworkManager-0.9.8.2-8.git20130709.fc19
then log in and leave karma (feedback).
Comment 14 Fedora Update System 2013-07-11 23:07:27 EDT
NetworkManager-0.9.8.2-8.git20130709.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Jirka Klimes 2013-07-30 03:36:05 EDT
*** Bug 989730 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.