Bug 981898 - Kernel 3.9 can not boot
Kernel 3.9 can not boot
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
x86_64 All
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-06 16:11 EDT by Herald van der Breggen
Modified: 2013-10-08 13:06 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-08 13:06:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Herald van der Breggen 2013-07-06 16:11:19 EDT
Description of problem:
After upgrade from fedora 17 to fedora 19, the default kernel hangs before going into the graphical mode. Nothing is written in /var/log/messages.

Booting the 3.8 kernel from fedora 17 (which was still present after the upgrade) works fine.

Most probably it is related to bug 981627, because the 3.9 kernel (also the fc17 version) never worked on my laptop.


Version-Release number of selected component (if applicable):
Both 3.9 versions fail in the same way:
kernel-3.9.8-100.fc17.x86_64
kernel-3.9.9-301.fc19.x86_64


How reproducible:
Boot one of these kernels. Maybe you need a Asus Zenbook UX31E (with SSD of 256GB).

Steps to Reproduce:
1. boot
2.
3.

Actual results:
Hanging boot process, graphical mode is not started, nothing is written to /var/log/messages.

Expected results:
full startup

Additional info:
Comment 1 Herald van der Breggen 2013-07-07 01:58:02 EDT
After updating grub2 (BIOS version) by

grub2-install /dev/sda
grub2-mkconfig -o /boot/grub2/grub.cfg

the laptop could again boot the 3.9 kernel. So it works for me now. 

I guess at least a note should be added to the documentation that this can happen and that a grub update fixes the problem.
Comment 2 Josh Boyer 2013-09-18 16:54:13 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.11.1-200.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.

Note You need to log in before you can comment on or make changes to this bug.