Bug 981991 - exceptions from findExistingInstallations should not be fatal
exceptions from findExistingInstallations should not be fatal
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-blivet (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:3594f40599ee1934961eef18521...
:
: 972546 994231 995159 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-07 11:22 EDT by jmp
Modified: 2014-12-08 17:27 EST (History)
13 users (show)

See Also:
Fixed In Version: python-blivet-0.20-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-06 14:05:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (472.50 KB, text/plain)
2013-07-07 11:22 EDT, jmp
no flags Details
File: anaconda.log (2.76 KB, text/plain)
2013-07-07 11:22 EDT, jmp
no flags Details
File: environ (441 bytes, text/plain)
2013-07-07 11:22 EDT, jmp
no flags Details
File: lsblk_output (8.45 KB, text/plain)
2013-07-07 11:22 EDT, jmp
no flags Details
File: nmcli_dev_list (3.38 KB, text/plain)
2013-07-07 11:22 EDT, jmp
no flags Details
File: os_info (179 bytes, text/plain)
2013-07-07 11:22 EDT, jmp
no flags Details
File: program.log (86.54 KB, text/plain)
2013-07-07 11:22 EDT, jmp
no flags Details
File: storage.log (266.82 KB, text/plain)
2013-07-07 11:23 EDT, jmp
no flags Details
File: syslog (118.11 KB, text/plain)
2013-07-07 11:23 EDT, jmp
no flags Details
File: ifcfg.log (486 bytes, text/plain)
2013-07-07 11:23 EDT, jmp
no flags Details
File: packaging.log (135 bytes, text/plain)
2013-07-07 11:23 EDT, jmp
no flags Details

  None (edit)
Description jmp 2013-07-07 11:22:27 EDT
Description of problem:
Problem with predifined software raid array

Version-Release number of selected component:
anaconda-19.30.13-1

The following was filed automatically by anaconda:
anaconda 19.30.13-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/devicelibs/mdraid.py", line 278, in name_from_md_node
    raise MDRaidError("name_from_md_node(%s) failed" % node)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 2196, in resolveDevice
    md_name = devicelibs.mdraid.name_from_md_node(devspec[5:])
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 2985, in parseFSTab
    options=options)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 2908, in findExistingInstallations
    (mounts, swaps) = parseFSTab(devicetree, chroot=ROOT_PATH)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 424, in reset
    self.roots = findExistingInstallations(self.devicetree)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 144, in storageInitialize
    storage.reset()
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
MDRaidError: name_from_md_node(md3) failed

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:UUID=2e45d8e4-3bac-4cac-955b-071039145131 rd.live.check quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19
Comment 1 jmp 2013-07-07 11:22:35 EDT
Created attachment 770018 [details]
File: anaconda-tb
Comment 2 jmp 2013-07-07 11:22:39 EDT
Created attachment 770019 [details]
File: anaconda.log
Comment 3 jmp 2013-07-07 11:22:43 EDT
Created attachment 770020 [details]
File: environ
Comment 4 jmp 2013-07-07 11:22:47 EDT
Created attachment 770021 [details]
File: lsblk_output
Comment 5 jmp 2013-07-07 11:22:52 EDT
Created attachment 770022 [details]
File: nmcli_dev_list
Comment 6 jmp 2013-07-07 11:22:55 EDT
Created attachment 770023 [details]
File: os_info
Comment 7 jmp 2013-07-07 11:22:59 EDT
Created attachment 770024 [details]
File: program.log
Comment 8 jmp 2013-07-07 11:23:04 EDT
Created attachment 770025 [details]
File: storage.log
Comment 9 jmp 2013-07-07 11:23:07 EDT
Created attachment 770026 [details]
File: syslog
Comment 10 jmp 2013-07-07 11:23:11 EDT
Created attachment 770027 [details]
File: ifcfg.log
Comment 11 jmp 2013-07-07 11:23:15 EDT
Created attachment 770028 [details]
File: packaging.log
Comment 12 jmp 2013-07-07 11:26:32 EDT
Weeks ago I was not successful with fc18 (anaconda not seeing the RAID
space and reporting "not enough space to install"), since 1991
FC18 being the very first distro I was not successful to install
(not able to find a 'trick' to bypass this glitch).

On FC19 situation is even worth, "unknown error" is displayed
shortly after presenting the screen to select the keyboard
(but not having the time to click on "continue"), according 
my understanding of log displayed (console 3 and 4), anaconda
was starting RAID array.

It is worth to note on the very same hardware with the same predefined 
Soft RAID array, el6, magia-3, slackware-14.0 are installing without a problem.
Comment 13 David Lehman 2013-07-08 12:56:59 EDT
It looks like you have an entry in an /etc/fstab that refers to some filesystem's block device as '/dev/md3'. This is causing problems because the md minor is not predictable during OS installation. You can either replace '/dev/md3' with an md array name, filesystem UUID or LABEL or you can comment out that line and any others like it prior to starting the installation.

This really shouldn't be preventing you from completing an installation -- the parsing of the existing /etc/fstab is only to help identify which filesystems/devices are part of which linux installations on your system to make custom storage configuration a bit easier. I need to make this a non-fatal error.
Comment 14 jmp 2013-07-08 13:50:48 EDT
FYI, /dev/md3 is the swap device (from a previous other distribution successful installation)
I agree with you,  it should be "Not fatal".
Comment 15 David Lehman 2013-08-08 13:30:43 EDT
*** Bug 995159 has been marked as a duplicate of this bug. ***
Comment 16 Michael Lausch 2013-08-10 06:26:54 EDT
Boot Fedora 19 DVD install from USB stick. The system has Fedora 18 installed and the disk layout is:
  /dev/sda is a windows disk
  /dev/sdb and /dev/sdc are used to form RAID1 devices
  First RAID 1 device is for /boot
  Second RAID 1 is for swap
  Third RAID 1 is for LVM 
     lvm is used for 
     loki_0-root    for the root partition
     loki_0-home for the /home partition
     loki_0-var     for the /var partition
     loki_0-virtdisks for the /var/lib/libvirt/images partition
     loki_0-vmware for an old virtual images partition
     loki_0-dvd    as a scratch partition for video conversion
     loki_0-local   for the /usr/local partition
     loki_0-Tmp   as a scratch partition
     

cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019\x20x86_64 debug BOOT_IMAGE=vmlinuz 
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
package:        anaconda-19.30.13-1
product:        Fedora
reason:         MDRaidError: name_from_md_node(md125) failed
release:        Cannot get release name.
version:        19
Comment 17 Doug McLaren 2013-08-13 12:32:19 EDT
*** Bug 994231 has been marked as a duplicate of this bug. ***
Comment 18 David Shea 2014-12-08 17:27:15 EST
*** Bug 972546 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.