Bug 995159 - MDRaidError: name_from_md_node(md1) failed
MDRaidError: name_from_md_node(md1) failed
Status: CLOSED DUPLICATE of bug 981991
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:3594f40599ee1934961eef18521...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-08 12:45 EDT by Doug McLaren
Modified: 2013-08-08 13:30 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-08 13:30:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (422.35 KB, text/plain)
2013-08-08 12:45 EDT, Doug McLaren
no flags Details
File: anaconda.log (3.69 KB, text/plain)
2013-08-08 12:45 EDT, Doug McLaren
no flags Details
File: environ (430 bytes, text/plain)
2013-08-08 12:45 EDT, Doug McLaren
no flags Details
File: install.log (107.46 KB, text/plain)
2013-08-08 12:45 EDT, Doug McLaren
no flags Details
File: lsblk_output (2.97 KB, text/plain)
2013-08-08 12:45 EDT, Doug McLaren
no flags Details
File: nmcli_dev_list (3.63 KB, text/plain)
2013-08-08 12:45 EDT, Doug McLaren
no flags Details
File: os_info (179 bytes, text/plain)
2013-08-08 12:45 EDT, Doug McLaren
no flags Details
File: program.log (40.70 KB, text/plain)
2013-08-08 12:45 EDT, Doug McLaren
no flags Details
File: storage.log (136.11 KB, text/plain)
2013-08-08 12:45 EDT, Doug McLaren
no flags Details
File: syslog (122.03 KB, text/plain)
2013-08-08 12:45 EDT, Doug McLaren
no flags Details
File: ifcfg.log (490 bytes, text/plain)
2013-08-08 12:46 EDT, Doug McLaren
no flags Details
File: packaging.log (135 bytes, text/plain)
2013-08-08 12:46 EDT, Doug McLaren
no flags Details

  None (edit)
Description Doug McLaren 2013-08-08 12:45:19 EDT
Description of problem:
Working on reproducing/coming up with more data to attach to bugzilla bug 994231.
Added "text" to the command line options, and chose text mode.

Version-Release number of selected component:
anaconda-19.30.13-1

The following was filed automatically by anaconda:
anaconda 19.30.13-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/devicelibs/mdraid.py", line 278, in name_from_md_node
    raise MDRaidError("name_from_md_node(%s) failed" % node)
  File "/usr/lib/python2.7/site-packages/blivet/devicetree.py", line 2196, in resolveDevice
    md_name = devicelibs.mdraid.name_from_md_node(devspec[5:])
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 2985, in parseFSTab
    options=options)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 2908, in findExistingInstallations
    (mounts, swaps) = parseFSTab(devicetree, chroot=ROOT_PATH)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 424, in reset
    self.roots = findExistingInstallations(self.devicetree)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 144, in storageInitialize
    storage.reset()
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
MDRaidError: name_from_md_node(md1) failed

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019\x20x86_64 quiet text BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.5-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19
Comment 1 Doug McLaren 2013-08-08 12:45:24 EDT
Created attachment 784478 [details]
File: anaconda-tb
Comment 2 Doug McLaren 2013-08-08 12:45:28 EDT
Created attachment 784479 [details]
File: anaconda.log
Comment 3 Doug McLaren 2013-08-08 12:45:31 EDT
Created attachment 784480 [details]
File: environ
Comment 4 Doug McLaren 2013-08-08 12:45:35 EDT
Created attachment 784481 [details]
File: install.log
Comment 5 Doug McLaren 2013-08-08 12:45:38 EDT
Created attachment 784482 [details]
File: lsblk_output
Comment 6 Doug McLaren 2013-08-08 12:45:42 EDT
Created attachment 784483 [details]
File: nmcli_dev_list
Comment 7 Doug McLaren 2013-08-08 12:45:46 EDT
Created attachment 784484 [details]
File: os_info
Comment 8 Doug McLaren 2013-08-08 12:45:49 EDT
Created attachment 784485 [details]
File: program.log
Comment 9 Doug McLaren 2013-08-08 12:45:53 EDT
Created attachment 784486 [details]
File: storage.log
Comment 10 Doug McLaren 2013-08-08 12:45:57 EDT
Created attachment 784487 [details]
File: syslog
Comment 11 Doug McLaren 2013-08-08 12:46:00 EDT
Created attachment 784488 [details]
File: ifcfg.log
Comment 12 Doug McLaren 2013-08-08 12:46:03 EDT
Created attachment 784489 [details]
File: packaging.log
Comment 13 Doug McLaren 2013-08-08 13:10:34 EDT
If there's something weird about md1, here's the details on it --

# mdadm --detail /dev/md1
/dev/md1:
        Version : 0.90
  Creation Time : Mon Sep 19 15:45:05 2011
     Raid Level : raid1
     Array Size : 663367424 (632.64 GiB 679.29 GB)
  Used Dev Size : 663367424 (632.64 GiB 679.29 GB)
   Raid Devices : 2
  Total Devices : 2
Preferred Minor : 1
    Persistence : Superblock is persistent

    Update Time : Thu Aug  8 12:08:38 2013
          State : clean 
 Active Devices : 2
Working Devices : 2
 Failed Devices : 0
  Spare Devices : 0

           UUID : 778b10a0:81a671ac:dfbdb0af:4b869ec5 (local to host beholder)
         Events : 0.106323

    Number   Major   Minor   RaidDevice State
       0       8       19        0      active sync   /dev/sdb3
       1       8        3        1      active sync   /dev/sda3
Comment 14 Doug McLaren 2013-08-08 13:12:21 EDT
... though I guess I don't know that md1 during the installation matches md1 while the system is in normal use, so here's all the devices --

# cat /proc/mdstat 
Personalities : [raid1] 
md1 : active raid1 sda3[1] sdb3[0]
      663367424 blocks [2/2] [UU]
      
md2 : active raid1 sdc1[2] sdd1[1]
      976760400 blocks super 1.2 [2/2] [UU]
      
md0 : active raid1 sdb1[0] sda1[1]
      52428736 blocks [2/2] [UU]
      
# mdadm --detail /dev/md0
/dev/md0:
        Version : 0.90
  Creation Time : Mon Sep 19 15:44:41 2011
     Raid Level : raid1
     Array Size : 52428736 (50.00 GiB 53.69 GB)
  Used Dev Size : 52428736 (50.00 GiB 53.69 GB)
   Raid Devices : 2
  Total Devices : 2
Preferred Minor : 0
    Persistence : Superblock is persistent

    Update Time : Thu Aug  8 12:11:40 2013
          State : clean 
 Active Devices : 2
Working Devices : 2
 Failed Devices : 0
  Spare Devices : 0

           UUID : 7789bc54:a532b91d:dfbdb0af:4b869ec5 (local to host beholder)
         Events : 0.53558

    Number   Major   Minor   RaidDevice State
       0       8       17        0      active sync   /dev/sdb1
       1       8        1        1      active sync   /dev/sda1

# mdadm --detail /dev/md2
/dev/md2:
        Version : 1.2
  Creation Time : Sat Dec 18 10:28:33 2010
     Raid Level : raid1
     Array Size : 976760400 (931.51 GiB 1000.20 GB)
  Used Dev Size : 976760400 (931.51 GiB 1000.20 GB)
   Raid Devices : 2
  Total Devices : 2
    Persistence : Superblock is persistent

    Update Time : Thu Aug  8 12:10:23 2013
          State : clean 
 Active Devices : 2
Working Devices : 2
 Failed Devices : 0
  Spare Devices : 0

           Name : beholder:2  (local to host beholder)
           UUID : 4861ea80:b0cfddd5:67d93cae:c25579bf
         Events : 1027503

    Number   Major   Minor   RaidDevice State
       2       8       33        0      active sync   /dev/sdc1
       1       8       49        1      active sync   /dev/sdd1
Comment 15 David Lehman 2013-08-08 13:30:43 EDT

*** This bug has been marked as a duplicate of bug 981991 ***

Note You need to log in before you can comment on or make changes to this bug.