Bug 982044 - RFE: Edit content spec maps from docbuilder
RFE: Edit content spec maps from docbuilder
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: DocBook-builder (Show other bugs)
1.1
Unspecified Unspecified
high Severity unspecified
: ---
: 1.4
Assigned To: Lee Newson
: Reopened
: 1008292 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-07 21:11 EDT by Misha H. Ali
Modified: 2014-05-14 02:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-14 02:03:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Edit this spec link (19.87 KB, image/png)
2013-12-05 21:55 EST, Matthew Casperson
no flags Details
Edit content spec (7.82 KB, image/png)
2013-12-05 22:11 EST, Matthew Casperson
no flags Details

  None (edit)
Description Misha H. Ali 2013-07-07 21:11:46 EDT
AFAIK, we still need to check out CSP maps to add new topics, but an "Edit the CSP Map" link would be very useful for minor edits such as:

* moving around topics/sections/chapters
* commenting out topics, uncommenting topics
* changing book metadata

I know a UI is being developed for the CSProcessor but maybe a greasemonkey script or something like that could be created in the interim for minor content spec changes?
Comment 1 Lee Newson 2013-09-16 23:04:05 EDT
*** Bug 1008292 has been marked as a duplicate of this bug. ***
Comment 2 Misha H. Ali 2013-12-04 22:36:50 EST
I'm changing the priority in an attempt to point out that this feature is sorely needed.

All that's needed here is a small link that allows you to Edit <Current CSP MAP> in the CCMS rather than open up a new CCMS tab, paste the CSP Map manually and edit it.
Comment 3 Lee Newson 2013-12-04 22:51:05 EST
You can do this from the index by clicking the ID, as for inside the book it should be implemented in the csprocessor builder. I'll make a note of bringing it up when we have the next sprint planning meeting.
Comment 4 Matthew Casperson 2013-12-05 21:55:53 EST
Created attachment 833394 [details]
Edit this spec link
Comment 5 Lee Newson 2013-12-05 22:03:02 EST
Marking this as ON_QA as what Matt implemented is probably better then including it along side the "Edit this topic" link.
Comment 6 Misha H. Ali 2013-12-05 22:09:54 EST
Awesome, thanks team!
Comment 7 Matthew Casperson 2013-12-05 22:11:11 EST
The content specs popover lists the content specs that the topic is included in, including the current spec. The pencil icon to the left of the spec is a link to edit the spec in the web ui.
Comment 8 Matthew Casperson 2013-12-05 22:11:43 EST
Created attachment 833402 [details]
Edit content spec
Comment 9 Misha H. Ali 2013-12-06 08:47:38 EST
FailedQA:

I tried to edit this spec (Infinispan Query Guide for JDG).

It took me to edit the Content Spec Map for the Hibernate Search Guide for WFK.

These two guides share a lot of content but I'm not sure why it can't tell the IDs apart.

Additionally, just a RFE, it would be great if this opened the map in a new tab by default.
Comment 10 Lee Newson 2014-01-12 19:45:39 EST
Adding to this, the spec id used in the "Report a bug" links is also incorrect.
Comment 13 Lee Newson 2014-01-14 21:59:59 EST
Fixed in the Docbuilder-Next, however a mass rebuild will need to be performed to fix any existing books.

Cause:

The id that was being set for SPEC_ID was being pulled from the "specId" variable however it should have been using "id" variable since it was in a callback and id was the reference what "specId" was when the process was started. As such there was a race condition and "specId" was being changed before the callback was executed.
Comment 14 Lee Newson 2014-01-23 06:41:42 EST
Moving to ON_QA since a mass rebuild has been triggered.
Comment 15 Matthew Casperson 2014-01-27 22:58:15 EST
Tried a couple of books and the edit spec link worked ok in all cases.
Comment 17 Lee Newson 2014-05-14 02:01:19 EDT
Looks like this is the offending commit that caused this regression:

https://github.com/pressgang-ccms/DocBuilder2/commit/f74130af4c26a0c3b5a826e272c1b2f4b5a2973e
Comment 18 Lee Newson 2014-05-14 02:03:34 EDT
Regression has been fixed and DocBuilder has been updated. Moving to CLOSED CURRENTRELEASE.

See: https://github.com/pressgang-ccms/DocBuilder2/commit/8eb2afc51616f051a9fb9f95b2a144a6fa19ec4c

Note You need to log in before you can comment on or make changes to this bug.