Bug 982157 - [ALL LANG] [RHSM CLI] orgs module with wrong username or password produces unexpected message: ''ascii' codec can't decode byte 0xe3 in position 0: ordinal not in range(128)'
[ALL LANG] [RHSM CLI] orgs module with wrong username or password produces un...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.10
x86_64 All
high Severity high
: rc
: ---
Assigned To: Carter Kozak
IDM QE LIST
: i18n
Depends On:
Blocks: rhsm-rhel510
  Show dependency treegraph
 
Reported: 2013-07-08 05:35 EDT by Lijun Li
Modified: 2013-10-01 09:50 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 09:50:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lijun Li 2013-07-08 05:35:44 EDT
Description of problem:
[ALL LANG] [RHSM CLI] orgs module with wrong username or password produces unexpected message: ''ascii' codec can't decode byte 0xe3 in position 0: ordinal not in range(128)'

Version-Release number of selected component (if applicable):
RHEL5.10 Beta 1 build:
subscription-manager-gui-1.8.11-1.el5

How reproducible:
100%

Steps to Reproduce:
1. Install latest RHEL5.10 Beta 1 build and run the following rhsm cli from terminal with local languages.


Actual results:
# subscription-manager orgs --username=stage_test_12 --password=test
'ascii' codec can't decode byte 0xe3 in position 0: ordinal not in range(128)


Expected results:
Should display Invalid Credentials

Additional info:
Comment 1 Carter Kozak 2013-07-11 12:02:14 EDT
I cannot reproduce this on the latest build, I assume this patch fixed the issue.

commit d3b2a827e8db6e47ae298ce5cae8fbe55b690964
Author: ckozak <ckozak@redhat.com>
Date:   Tue Jul 2 11:14:14 2013 -0400

    977535: cli uses utf8 too
Comment 2 Sharath Dwaral 2013-07-16 16:29:55 EDT
Version:

# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-1.8.13-1.el5_9
subscription-manager-migration-1.8.13-1.el5_9
python-rhsm-1.8.13-1.el5_9
subscription-manager-migration-data-1.11.3.1-1.git.1.78afd75.el5
subscription-manager-firstboot-1.8.13-1.el5_9
subscription-manager-debuginfo-1.8.13-1.el5_9
subscription-manager-gui-1.8.13-1.el5_9

Verification:

# subscription-manager identity 
Current identity is: 1895c4cf-560a-4ee8-af8e-28f00b93f3f9
name: dhcp129-119.rdu.redhat.com
org name: 6752574
org ID: 6752574

(INVALID CREDENTIALS)
# subscription-manager identity --regenerate --username stage_test_12 --password test --force 
Invalid username or password. To create a login, please visit https://www.redhat.com/wapps/ugc/register.html

Additional Information:

# LANG=zh_CN.UTF-8 subscription-manager identity --regenerate --username stage_test_12 --password test --force 
无效用户名或者密码。要创建登录,请访问 https://www.redhat.com/wapps/ugc/register.html
[root@dhcp129-119 ~]# LANG=zh_TW.UTF-8 subscription-manager identity --regenerate --username stage_test_12 --password test --force 
無效的使用者名稱或密碼。若要建立登錄帳號,請至 https://www.redhat.com/wapps/ugc/register.html

Works for UTF8 chars as well

VERIFIED

Note You need to log in before you can comment on or make changes to this bug.