Bug 982194 - sosreport handles --name and --ticket-number parameters incorrectly
sosreport handles --name and --ticket-number parameters incorrectly
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sos (Show other bugs)
5.10
Unspecified Unspecified
low Severity low
: rc
: 5.10
Assigned To: Bryn M. Reeves
BaseOS QE - Apps
:
: 982195 (view as bug list)
Depends On: 822113 1185093 1232945
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-08 07:26 EDT by Miroslav Hradílek
Modified: 2015-11-18 06:19 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When using sosreport in interactive mode, the "--name" and "--ticket-number" command-line options did not have any effect. As a consequence, the default option values in interactive sosreport prompts were not updated with the provided options. Now, "--name" and "--ticket-number" work as expected, and when either of them is provided in sosreport's interactive mode, the interactive prompts reflect it accordingly.
Story Points: ---
Clone Of: 822113
Environment:
Last Closed: 2013-10-15 15:27:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Hradílek 2013-07-08 07:26:03 EDT
This seems to be only partialy fixed on RHEL5

+++ This bug was initially created as a clone of Bug #822113 +++

-----><8

1) seems working partially:

$ sosreport -o general --ticket 123 --name sir
...
Press ENTER to continue, or CTRL-C to quit.

Please enter your first initial and last name [dhcp-25-214]: 
Please enter the case number that you are generating this report for: 
...
Your sosreport has been generated and saved in:
  /tmp/sosreport-sir.123-20121129183157-4293.tar.xz

So provided ticket and number are actually used, but not propagated to user dialog (I hit enter twice).

-----><8
Comment 1 Miroslav Hradílek 2013-07-16 06:48:38 EDT
*** Bug 982195 has been marked as a duplicate of this bug. ***
Comment 3 Andrius Benokraitis 2013-10-15 15:27:37 EDT
No additional minor releases are planned for Production Phase 2 in Red Hat Enterprise Linux 5, and therefore Red Hat is closing this bugzilla as it does not meet the inclusion criteria as stated in:
https://access.redhat.com/site/support/policy/updates/errata/#Production_2_Phase

Note You need to log in before you can comment on or make changes to this bug.