Bug 982195 - sosreport handles --name and --ticket-number parameters incorrectly
Summary: sosreport handles --name and --ticket-number parameters incorrectly
Keywords:
Status: CLOSED DUPLICATE of bug 982194
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sos
Version: 5.10
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: 5.10
Assignee: Bryn M. Reeves
QA Contact: Miroslav Hradílek
URL:
Whiteboard:
Depends On: 822113 1185093 1232945
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-08 11:27 UTC by Miroslav Hradílek
Modified: 2018-11-30 22:02 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When using sosreport in interactive mode, the "--name" and "--ticket-number" command-line options did not have any effect. As a consequence, the default option values in interactive sosreport prompts were not updated with the provided options. Now, "--name" and "--ticket-number" work as expected, and when either of them is provided in sosreport's interactive mode, the interactive prompts reflect it accordingly.
Clone Of: 822113
Environment:
Last Closed: 2013-07-16 10:48:38 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Miroslav Hradílek 2013-07-08 11:27:23 UTC
This seems to be only partialy fixed on RHEL5

+++ This bug was initially created as a clone of Bug #822113 +++

-----><8

1) seems working partially:

$ sosreport -o general --ticket 123 --name sir
...
Press ENTER to continue, or CTRL-C to quit.

Please enter your first initial and last name [dhcp-25-214]: 
Please enter the case number that you are generating this report for: 
...
Your sosreport has been generated and saved in:
  /tmp/sosreport-sir.123-20121129183157-4293.tar.xz

So provided ticket and number are actually used, but not propagated to user dialog (I hit enter twice).

-----><8

Comment 1 Miroslav Hradílek 2013-07-16 10:48:38 UTC

*** This bug has been marked as a duplicate of bug 982194 ***


Note You need to log in before you can comment on or make changes to this bug.