Bug 982309 - rhq measurement metric graph is not visible if date is not specified explicitly
rhq measurement metric graph is not visible if date is not specified explicitly
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: UI (Show other bugs)
JON 3.2
x86_64 Linux
urgent Severity high
: ER01
: JON 3.2.0
Assigned To: Stefan Negrea
Mike Foley
:
Depends On:
Blocks: 951619
  Show dependency treegraph
 
Reported: 2013-07-08 11:49 EDT by Armine Hovsepyan
Modified: 2015-09-02 20:01 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-02 15:35:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
metrics_graphs_not_visible (109.42 KB, image/png)
2013-07-08 11:49 EDT, Armine Hovsepyan
no flags Details

  None (edit)
Description Armine Hovsepyan 2013-07-08 11:49:41 EDT
Created attachment 770555 [details]
metrics_graphs_not_visible

Description of problem:
rhq measurement metric graph is not visible if date is not specified explicitly

Version-Release number of selected component (if applicable):
build:d5b6714

How reproducible:
always

Steps to Reproduce:
1. install rhq 4.5
2. upgrade rhq to 4.9
3. migrate data from old db to new
4. rhq agent -> monitoring ->  metrics
5. click on graphs sub-menu link

Actual results:
no graph is visible

Expected results:
graph with default (i guess 4 hours) date should be visible

Additional info:
screenshot attached
Comment 1 Stefan Negrea 2013-08-22 18:22:45 EDT
Please re-run the tests. There were changes in the UI, the storage cluster, and the data migrator since the bug was reported. Also, the default time window is 8 hours so the data should be visible in the UI if there were any metrics collected in that time interval. If the time between shutting down RHQ 4.5 and starting the new RHQ 4.9 server is bigger than 8 hours than no data will be visible until a fresh set of metrics is delivered from the agent to the server.

Please retest and update the BZ if the problem persists. And please specify if any data is visible if the time window is manually updated or no data is visible at all.
Comment 2 Armine Hovsepyan 2013-08-26 05:22:50 EDT
graphs of metrics are changed and fixed, the issue for availability graph present.

Expected -> http://d.pr/i/2ObZ
actual   -> http://d.pr/i/theQ
Comment 3 Armine Hovsepyan 2013-08-30 08:59:00 EDT
measurement graphs are fixed
new bug for availability graph created #1003002

Note You need to log in before you can comment on or make changes to this bug.